Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Medieval Lords problem


  • Please log in to reply
2 replies to this topic

#1 sn0zb0z

sn0zb0z

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:UK
  • Local time:03:36 AM

Posted 21 March 2009 - 08:15 AM

I have two computers which I have tried to install the game medieval lords on.

For the first PC I am sure I did once install it, but it was way too slow to play it. The computer now says it doesn't have the right graphics card and I don't think it is worth buying another card for it to work as the PC would probably be too slow.

The second PC will install it fine, but as it is Windows Vista is will not play it. I have tried the compatibility mode so it is running in XP or 2000 which the game should run in, but it doesn't work. All the other specs are fine on this PC. I don't want to make the PC XP or spend loads of money just for this one game to work, but is there anything at all I can do to make work on this PC?

Thanks :thumbsup:

BC AdBot (Login to Remove)

 


#2 jgweed

jgweed

  • Members
  • 28,473 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chicago, Il.
  • Local time:10:36 PM

Posted 21 March 2009 - 10:09 AM

I would suggest checking and updating the drivers for your video card on both machines, especially the one running Vista.
Regards,
John
Whereof one cannot speak, thereof one should be silent.

#3 sn0zb0z

sn0zb0z
  • Topic Starter

  • Members
  • 262 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:UK
  • Local time:03:36 AM

Posted 21 March 2009 - 01:11 PM

The game tells me I don't have a video card for the first PC so I can't do that. I think using this PC is probably not an option at all.

I'm not really sure how to check and update drivers anyway, but everything is fine on the Vista PC and it shouldn't need updating. The problem is that it is Vista and even checking and updating drivers will not change this problem surely?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users