Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Having trouble accessing XP shared folders from XP/Vista PCs


  • Please log in to reply
1 reply to this topic

#1 Deadmoney

Deadmoney

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:59 AM

Posted 14 March 2009 - 11:56 AM

I've ready through a lot of posts around XP/Vista networking/sharing, but I still was not able to solve my issue. Sorry for the lengthy post, it's my first time and I don't want anyone wasting their time because I didn't provide enough info. (especially the part where I messed everything thing up myself)

My main problem is I have a XP Pro sp3 desktop and would like to share it's folders on the network

I currently have 2 desktops (XP Pro with the sharing problem and Vista Ultimate 64 bit) and 2 laptops (XP Pro and Vista). The XP desktop has a lot of disk space and I've used it as storage for my network for years. Yes, the network sharing has worked for years and I recently messed it up.
Both desktops are connected via a wire to my Linksys Router (Wireless-N Gigabit Router WRT310N). I setup a very basic dhcp network with all machines in the same workgroup. The laptops are connected wirelessly, but I don't think we need to worry about them.

Recently I found viruses and other bad stuff on the XP desktop so I used Malwarebytes to help clean it up. (Props to the posts in other forums for helping me out). During the process I also downloaded HiJackThis and pulled some stuff from the registry entries. I believe this is where I made a mistake because my network card would no longer work. At least this is what I noticed, I may have messed up something somewhere else and only noticed the network card. What I mean by no longer working is the status was 'This device is working properly', but it would not get an ip address.
I tried to roll back the drivers, no improvement.
I downloaded the latest drivers (Interl® Pro/1000 CT Network Connection) and still no improvement. I then noticed a message stating something about no DHCP client. Sorry I didn't write down what I saw or where I saw this, but I believe it was in the bottom right hand corner (tray area - on top of my network connection). The image in the tray indicated, the card was trying to connect to the router (which I couldn't even ping) but stated something about missing or no DHCP client available. I realize it should say can't find DHCP server (i.e. the router), but I'm 99% sure it said client, which made me think I messed up my local networking files.

I read many articles around XP/Vista networking trying to troubleshoot it myself. I uninstalled 'Networking Services' via add remove windows components, then reinstalled and that seemed to do the trick.

At this point my XP desktop can see all other machines on the network and their shared assets (via windows explorer and \\machine name or ip).
None of my other machines (1 laptop which is XP Pro, so I don't think it's a Vista/XP issue) can see the XP desktop though. I've tried pinging the ip of the XP desktop from 2 other machines and nothing comes back. My router client table sees all machines just fine.

I've uninstalled and reinstalled 'File and Print Sharing for Microsoft Networks' and that didn't fix it.
I'm not really sure what to try next. Any tips/advice would be greatly appreciated.

Thank you for your time.

Edited by Deadmoney, 14 March 2009 - 11:58 AM.


BC AdBot (Login to Remove)

 


#2 Desion

Desion

  • Members
  • 135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:59 AM

Posted 19 March 2009 - 07:27 AM

On the PCs your having file sharing problems with, check and make sure your firewall is configured to Allow File and Printer Sharing. Just as a troubleshooting step, try temporarily turning off your firewall and then try to see if you can use file sharing, if not then its not a firewall issue.

Another step if the above dosent work, make sure your labtop is in the Access Control List (ACL) for the folder you wish to share and have adequate permissions to the folder(s) on the remote computer.

Please let me know of your results.
Interesting Links:
Softpedia - Online downloads encyclopedia
W3Schools - Website Programming Tutorials
PC World - Everything about technology
Wikipedia - Online Encyclopedia
Photobucket - Free Image Hosting

"I don't support network bridges, they support me."




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users