Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Print spooler is ON but printer still not connecting


  • Please log in to reply
2 replies to this topic

#1 koolaid513

koolaid513

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:26 AM

Posted 08 March 2009 - 08:24 PM

Hi, I promise all of you that I have done my fair share of searching on the internet before I have posted here. I can't seem to find anything that fits my problem exactly. I recently bought a new printer/scanner which is an EPSON Stylus NX100. Several days before I installed it, I got some nasty viruses on my computer. Unable to fix them on my own I had to take it to a service center to get cleaned up. With all the viruses gone I installed my new printer. The printer fully installs, but when I go to print my test page, or any page for that matter, nothing comes out. When I open up the print que screen it says that the doc is printing(sometimes) and other times it just doesn't appear. When I click on "connect" under the printer name it says that it cannot connect. When I do restart or start my print spooler the "services.msc" console says it is running. At this point I try to print again and still it is not connected. I am thinking maybe since I removed some big viruses that something got deleted within my print spooler file or something of the sort when my comp was being cleaned. I don't know if this is how things work though. Sometimes when I would try to start or restart my spooler or my RPC I would get this error: res://C:\WINDOWS\System32\mmcndmgr.dll/views.htm. ONE time, only once, I got a 1067 Error. After many attempts at trying to fix this that only happened once. On top of all of this, when I start my computer the "System 32" folder containing many other processes and folders comes up immediately after I have logged on . One of the folders..."DRVR..." is in blue letters while all of the other folders or programs(not sure what they are) are in black type.

So far I have:
Started and restarted my print spooler and restarted my computer
Re-installed the printer
Started and restarted RPC

Everything regarding a "spooler" or RPC problem I have searched for on Google has led me nowhere. Thanks for your help!

BC AdBot (Login to Remove)

 


#2 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:11:26 PM

Posted 09 March 2009 - 12:24 AM

Sounds like a faulty virus removal. Sometimes it is best to look on the internet and do your own virus removal. Sometimes once you have been infected by a bad one (Rootkit or heavy trojan infection), it is best to reinstall the operating system. I will look into some things for you, but it seems like you have tried the stuff I would have. Try getting into safe mode and turn on your print spooler. See if you can print from there and let us know.

Gavin Seabrook

 


#3 koolaid513

koolaid513
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:26 AM

Posted 09 March 2009 - 06:20 PM

I tried turning the spooler and the RPC on in safe mode. It said that I was not allowed to turn either on in safe mode.

In the system 32 Folder that comes up after my start up, there is a folder titled: DRVSTORE that is in blue print. Within this folder is 7 other folders with random letters and numbers, also all of them containing blue print.

Also in the system 32 folder are two spool apps: SPOOLSV, which is an application, and SPOOLSS.DLL which is an app extension. I am not sure if maybe there should be more than this?

When I was looking to fix this about two weeks ago I thought I had found somewhere that it is a possibility that I am missing part of an app or something that deals with the spooler; I thought I read that this can happen after heavy virus removal. At the time though I had to go somewhere and havn't got back around to fixing this thing until now. Now I am unable to find this info again.

Again, thanks for ANY help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users