Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need to replace user32.dll - no success - can you help?


  • Please log in to reply
3 replies to this topic

#1 blenny

blenny

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:11:18 AM

Posted 08 March 2009 - 08:11 PM

Greets - Love this website BTW

Somehow the user32 file was removed and windows won't boot. I have been trying to use the windows recovery console to get the file back into place. Unfortunately for me the commands I'm using dont' jive in the console. Hopefully it's just me doing something incorrect. I have the disk installed and have completed the admin pw etc.

These are the directions I'm trying to complete:
When you see the Welcome To Windows screen, press r to use the Recovery Console. In the instructions below, drivername is the name of the file listed in the error message. (After each command, press ENTER.)

Type in your login information. Then, at the command prompt, type:

cd windows\system32\drivers

Then, type:

ren drivername.sys drivername.bak

Finally, type:

copy cd-rom:\i386 drivername


When I command prompt C:\WINDOWS I type "cd windows - etc" I get a response that the system cannot find the filer or directory specified?

I have also tried microsofts fixes with similar results. Can someone help me? Hopefully this is easy and certainly I will follow directions exactly and hopefully clarify questions.

Best Regards
blenny

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,738 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:18 PM

Posted 09 March 2009 - 09:30 AM

Hi :thumbsup:.

What is the link for these directions, please?

Louis

#3 blenny

blenny
  • Topic Starter

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:11:18 AM

Posted 09 March 2009 - 06:57 PM

Thanks for taking a look at my posting Louis - I'm grateful for your help.

So here's where I'm at - I was able to burn an ISO disk similar to what the issues were w/ AVG AV. Guess it was finding the user32.dll and calling it malware. So they provided a fix w/ a burnable ISO. I ran that and was able to get into the system. I'm sure I screwed it up somewhere b/c it appears as if a new version of windows loaded (or was in place) as all my links were gone etc. My files remained. Annoying really.

Heck - so here's where it gets worse. My futile attempts have recently been trying to get rid of malware.. (Thus the accidental deletion of the user32 file). Therefore when I was able to get into windows (fresh version), all the malware was back. I had a big screen saying my windows was infected yadda yadda yadda. So I ran SuperAV which it found several items (3). Of course I had to reboot and upon reboot, I'm now locked out. When I select the administator profile, it starts opening and then shuts out. Can't get into windows. I also tried to do this in safe mode - same thing. Can't get in. I also tried to reboot w/ last working configuration - didn't work.. This is getting rough.

1. Is there a way I can get into my profile? Any ideas why it maybe shutting down right away?
2. Or is there a way I can recall my previous profile through System recovery/DOS commands?

My preference would be #2.

Other ideas? I'm looking at reformatting the drive w/ a fresh install as these issues continue to mount.

Many thanks and my best regards to you Louis for helping me.

blenny.

#4 OldGrumpyBastard

OldGrumpyBastard

  • Members
  • 781 posts
  • OFFLINE
  •  
  • Location:"Way South of 'da Bridge"
  • Local time:12:18 PM

Posted 09 March 2009 - 07:33 PM

If you have an Xp CD I would try SFC /SCANNOW :

http://www.bleepingcomputer.com/forums/t/43051/how-to-use-sfcexe-to-repair-system-files/
Does this look like an OldGrumpyBastard or what?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users