Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External HD Won't Mount


  • Please log in to reply
2 replies to this topic

#1 dobber1978

dobber1978

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:08:07 PM

Posted 01 March 2009 - 12:22 PM

Ok, new to Linux, using the Ubuntu platform and I can't mount my external HD

Basically I plug it into the USB and I get the error message

First Error:

Cannot mount volume
Unable to mount the volume
Details
$logfile indicates unclean shutdown (0,0) Failed to mount '/dev/sdf1'; Operation not supported Mount is denied because NTFS is marked to be in use. Choose one action; Choice 1: If you have Windows then disconnect the external device by clicking on the safely remove hardware icon in the taskbar then shutdown windows then you can use the force option for your own responsibility. For example type the command line: mount -t ntfs -3g /dev/sdf1/media/disk -o force Or add the option to the relevant row in the /ect/fstab file: /dev/sdf1/media/disk ntfs-3g force 00

Second Error

Unable to mount 80.0 GB Media
DBus error.org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible cause include: the remote application did not send a reply, the reply timeout expired, or the network connection was broken.

Hopefully I copied those error messages over properly

Ok, those were the two errors, I tried to fource the mount as per Error 1 and it did not correct anything, keeps telling me: Mount: Only Root Can Do That

Not sure what this root is?

Has anybody had these issues before?
Thanks
Jeff

BC AdBot (Login to Remove)

 


#2 BlackSpyder

BlackSpyder

    Bleeping Big Rig


  • BC Advisor
  • 2,456 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Huddleston, VA USA (Home Sweet Home)
  • Local time:08:07 PM

Posted 02 March 2009 - 12:56 AM

Root is the Admin so you need to add the "sudo" (Super User Do) command in front of the command like such:
sudo mount -t ntfs -3g /dev/sdf1/media/disk -o force

It may prompt for a password its the password you use to login.

but forcing is dangerous, if it fails you may not be access the data from either windows or linux ever again.

try doing as listed using "Safely Remove Hardware" in windows but leave the drive attached and powered on while shutting down windows and booting into Ubuntu.

Edited by BlackSpyder, 02 March 2009 - 12:56 AM.

Posted Image




#3 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,260 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:04:07 PM

Posted 03 March 2009 - 03:40 PM

This error is most commonly caused when an NTFS volume is improperly dismounted (i.e. removing a USB drive without clicking the "Safely Remove Hardware" button in Windows or the umount command in Linux, or when the computer is shut down ungracefully due to power failure or system crash.)

If you have access to a Windows 2000 or newer installation, connect the drive to it and run chkdsk, that should clear up the error which is preventing the mount action.

There is also a program for Linux called NTFSfix which will reset the NTFS journal, clearing the error. I've not used it before so cannot vouch for it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users