Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Msvcr71.dll and LoadLibrary error


  • Please log in to reply
2 replies to this topic

#1 elomont

elomont

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Local time:12:29 PM

Posted 27 February 2009 - 08:40 AM

I just wanted to add this bit of information in case someone else has the same problem.

My girlfriends computer, upon startup, would always give me a Msvcr71.dll error. In my case it was related to the free Avast Antivirus that was on my startup list. I know it was related to the Avast because it was the only thing checked on my startup list in msconfig. Well, along with normal things that needed to be there. Side note, I would also get the same error when I tried to start her AIM Messenger (Msvcr71.dll missing).

After having the problem for a couple weeks and trying to do some research and troubleshooting BEFORE I posted my problem on BC I finally fixed the problem this morning. I went through some of the forums on BC and some other sites and tried all the recommendations to no avail. Downloading a new dll from www.dlldump.com. Renaming my old Msvcr71.dll. Unregistering it. Registering it (to which I would receive the LoadLibrary error noted in the Topic Description line). Searching to to see where it was located using Windows Explorer. On and on and on, over and over again. All these avenues left me high and dry and STILL with the same error.

So, what cured the problem was this. I read a forum about having AVG Antivirus installed and the trouble some people had with trying to remove it in normal startup and how it failed. The same thing happened to me when I tried to remove it. They recommended starting in safe mode and removing it that way. Before I shut down I removed Avast Antivirus and tried again to remove AVG Antivirus, but it would not let me remove it. Off to safe mode we go. In safe mode I removed AVG Antivirus. Success! No failure errors. Back to regular startup (Is there a tech term for "normal startup" that someone reading this can inform me of? Thanks.) Upon regular startup, again, success! No failure errors. I downloaded Avast Antivirus and I was good to go. No more Msvcr71.dll errors.

FYI for anyone with a similar problem.

Edited by elomont, 27 February 2009 - 08:47 AM.


BC AdBot (Login to Remove)

 


#2 Keithuk

Keithuk

  • Members
  • 957 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:29 PM

Posted 28 February 2009 - 11:47 AM

My girlfriends computer, upon startup, would always give me a Msvcr71.dll error.


Well Msvcr71.dll is Microsoft® C Runtime Library which affects most of Windows running apps. You can do a search on Microsoft for any updates to Microsoft® C Runtime Library. :thumbsup:

Keith

Windows ME (spare computer)
Windows XP 2002 Professional SP3 (desktop computer)
Windows 7 Professional SP1 32bit (laptop computer)

Windows 8 64bit spare drive for laptop computer


#3 Smithsam

Smithsam

  • Banned
  • 96 posts
  • OFFLINE
  •  
  • Local time:11:29 AM

Posted 24 March 2009 - 06:14 AM

this problem related from java try to read this link

http://www.duckware.com/tech/java6msvcr71.html




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users