Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Auto Map Network Drives with a Wireless NIC


  • Please log in to reply
5 replies to this topic

#1 DustN

DustN

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:08:10 PM

Posted 25 February 2009 - 10:03 PM

I have a mostly wired network in my home. My laptop however usually connects via wireless. Because of the wireless connection, I've always had issues with re-connecting network drives on startup. So, I've written a batch file that runs on login that will map my network drives only after the wireless card has automatically connected to my home network and the gateway address is accessible. I recently had to wipe my laptop (stupid vista blue screen) and up until that point, my script was working like charm. Now, after net use commands, I am receiving "The network connection could not be found" errors and I can't figure out why. I hope someone can offer some input. You can ignore many of the echo's as I'm just as much into looks as I am into functionality :thumbsup:

@echo off
:waitloop
echo Waiting for wireless connection....
Ping 127.0.0.1 -n 2 > nul
ipconfig |find /i "192.168.0.1" >nul
if errorlevel 1 goto waitloop
echo.
echo Connected Successfully!
echo.
echo Disconnecting Previous Network Drives
echo *
echo **
echo ***
net use W: /delete
net use X: /delete
net use Y: /delete
net use Z: /delete

echo Reconnecting Network Drives
echo *
echo **
echo ***
net use w: \\192.168.0.146\Volume_1 /persistent:no
net use X: \\192.168.0.150\C /persistent:no
net use Y: \\192.168.0.150\F /persistent:no
net use Z: \\192.168.0.150\External_G /persistent:no

pause

BC AdBot (Login to Remove)

 


#2 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:05:10 PM

Posted 26 February 2009 - 03:01 AM

Make sure that your network discover is on and set to public. You can do this from your network connections menu in the control panel.

Gavin Seabrook

 


#3 DustN

DustN
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:08:10 PM

Posted 27 February 2009 - 12:57 AM

Yup. I've made sure that these settings are correct. I've played with my trendmicro firewall and ensured that my NAS and other workstation are on the same workgroup. I really believe that it has something to do with Windows Vista not identifying my wireless network fast enough after start up. Is there anyway to speed this up? It was working fine before, why not now? :thumbsup:

#4 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:05:10 PM

Posted 01 March 2009 - 03:24 AM

What changes have you made software/hardware wise on your entire network?

Gavin Seabrook

 


#5 DustN

DustN
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:08:10 PM

Posted 01 March 2009 - 08:56 PM

I haven't made any changes. The only change that was made was restoring a factory image on my laptop. I'm still stumped on this issue.

#6 gavinseabrook

gavinseabrook

  • Members
  • 773 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:El Paso
  • Local time:05:10 PM

Posted 02 March 2009 - 09:53 PM

Try disabling any type of software based wireless connection software (such as intel pro software/linksys connection manager) and use the built in windows wireless connection.

Gavin Seabrook

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users