Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Winsock/malware infestation


  • Please log in to reply
1 reply to this topic

#1 uninvited

uninvited

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:15 AM

Posted 25 February 2009 - 12:20 PM

winsock vista SP1, 32 bit OS trouble

i was infested by malware, deleted some files including google desktop start up and apple bonjour start up which were identified by Autorun and my wireless has proceeded to stopped working.

when i start my laptop it takes a minute to load after i have typed my password and after that minute the screen goes black with only the cursor on the screen, then windows finally loads and says it is impossible to start the event register,
it also says winsock has failed to load.

i have tried to i run netsh winsock reset but in this case i got the following error message;
impossible to start initialization function InitHelperDll into NSHHTTP.DLL error code 11003.

if a put the mouse on the wireless icon (low right) the pop up is telling:
connection status: unknown, start of the group or dependency service has failed to start

i cannot restore the Vista operation system. I try to recover
the operating system at one point of 3 days ago but i get error messages:
system has not been restored due to an unspecified error

when i type "msinfo32" in "run" and look at components > network > protocol it says it cannot collect information as the windows management files are removed or missing

when i deleted the winsock, winsock 2 files, the startup was quick, the wireless would work but with limited connectivity and doesnt connect to the internet, i ran msinfo32 again and this time it was blank under protocol (microsoft support says i should have 10 files there) now i have reinstated the winsock and winsock 2 files it has slowed down and the wireless group has failed to start again!

when i googled error 11003 it says this is a non recoverable error, does this mean even if i reload vista i will still have the same problem?!

i have tried to reinstall bonjour but it says i do not have the privileges to do so, (even though i'm the admin) i also can't start my windows firewall now either!

HELP!

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:09:15 PM

Posted 25 February 2009 - 04:08 PM

does this mean even if i reload vista i will still have the same problem?!

If you reload the OS it should be fine
I had this problem last week after an infection. After messing with it for a week, I finally reinstalled
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users