Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

TweakDun can't save Hosts file after updating


  • Please log in to reply
3 replies to this topic

#1 Frank D

Frank D

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:27 AM

Posted 04 June 2005 - 07:10 PM

I'm trying to use TweakDun 3.0 to optimize my hosts file (Win XP Pro w/SP2, IE 6 browser, dial-up networking), but it goes into an infinite loop.

It goes through the procedure of updating the Hosts file and importing Favorites, but then displays error message: "TweakDun exited without saving hosts. Would you like to restore your previous hosts file?" If I click Yes it crashes. If I click No it says "No hosts file. Starting from scratch." After it creates the hosts file it displays the message "Run-time error '5': Invalid procedure call or argument." The only option is to click on the OK button, exiting TweakDun. Restarting TweakDun produces the first error message again (see above).

Any clues? Thanks

Frank D

BC AdBot (Login to Remove)

 


#2 jgweed

jgweed

  • Members
  • 28,473 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chicago, Il.
  • Local time:02:27 AM

Posted 04 June 2005 - 09:30 PM

Have you tried deleting the application, then downloading a fresh version, and installing it?
Regards,
John
Whereof one cannot speak, thereof one should be silent.

#3 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:05:27 PM

Posted 04 June 2005 - 09:54 PM

Thoughts:
Run scandisk in Safe Mode to make sure your hard drive is Ok.
Download TweakDUN again because it may be corrupted.

EDIT - like John said.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#4 Frank D

Frank D
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:27 AM

Posted 05 June 2005 - 10:17 AM

Thanks for both suggestions, Rimmer and jgweed.

I ran ScanDisk (actually Chkdsk) with no problems found by it. I uninstalled TweakDun, cleaned the registry using RegistryFix to get rid of any leftover references to TD, then installed TweakDun again. Again I got exactly the same results. . . . However!!!!

By trial and error I found that if I limited TD's importation of my Favorites folder to one subfolder at a time (e.g., Movies, Maps, etc.), that it works! :thumbsup:

So, I don't know what the probem was (maybe a bad item in the Favorites folder or at 889 entries it was just too large), but I believe the problem has been solved. Thanks for your help!

Frank D

Edited by Frank D, 05 June 2005 - 03:58 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users