Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Morrowind Music Error at title screen - Tryed All fixes, need help!


  • Please log in to reply
7 replies to this topic

#1 Psycho Nomad

Psycho Nomad

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:05:10 AM

Posted 23 February 2009 - 08:21 AM

Hey there, I've been playing modded morrowind for literally ages fine, havn't played it in a few weeks, then i decided to play it last night. At first i't worked fine, got into a save game went around a bit. Then i decided to put it through the Flat screen tv with a (Dongle?) Which i do allot. When the image came up on the TV the fullscreen game had reverted to windowed mode showing only a black screen, offset to one side so u could see part of the desktop behind it. You could also hear the game sounds in the background so it was still running, i messed around a bit trying to get the game to respond to no avail so i decided to try end the process via the task manager. so i opened the task manager and it opened UNDER the dam game screen so i couldnt get the the title bar to pull it across to end the process form the list as i couldn't get to it as when u try to click on the game screen the mouse dissapeared followed by a mashing of alt-tab to try get it back, unreliably, it was obviously really not liking whatever had happened, so i decided to CTRL-ALT-DLT and restart. So i did. After the re-boot i fired morrowind back up and it went through the usual process as normal, until...

As it came to the title screen it froze, not running the little visual it does normally and an error message popped up saying "music error: cannot play music file. data files/music/special/Morrowind title mp3" and the game immediately closes, prompting a 'morrowind has stopped working, windows is searching for a solution to the problem blah blah'.

This has never happened before. So OK, maybe the file is corrupt. I go to the file it can't play, right click -> play... it plays fine... So, ok, the next thing i try is changing the name of the file to see if it bypasses it. i change it to something else, fire up morrowind again, it goes through to the title screen and this time plays through the visual with no sound, so i think "GREAT!" i load up my save game, the enviroment loads and after 2 seconds, it opens the inventory and brings up a similar error message "music error canno't play file *blah blah[name of .mp3 its trying to play for the background music, it changes depending on what track its trying to play]*.

So dam, its more of an integral problem than i had hoped, the file's aint corrupt. So after a little more research i had found out quite few people had been getting the same issue, and also came across that it may be a CODEC problem. The instructions for this specific problem on the Elder Scrolls official site, fixes for morrowind section states that -

[4c] Music error - "Can not play file. Data Files/Music/Special/morrowind title.mp3"

If you are getting this music error, do not fear! Your computer is probably just using a CODEC to play MP3 files that Morrowind cannot use (Morrowind is pretty picky about this).

First, make sure Windows Media Player is your default playback application for MP3 files (Morrowind needs this). Right-click any MP3 file (Morrowind's are located in C:\Program Files\Bethesda Softworks\Morrowind\Data Files\Music\...) and select "Open with", click "Choose program", choose Windows Media Player from the list, check the box "Always use the selected program," then click OK.

The following two paragraphs are for Windows XP users only - If the previous suggestion doesn't correct your problem, then download Nightmare's CODEC Reset Utility, extract it (DON'T FORGET TO EXTRACT IT!), and run the file "MP3FIX.BAT."

If that still doesn't correct the problem, then read the readme that came with the CODEC Reset Utility and follow the instructions to completely reset your system's CODECs to their defaults.



So i go through the initial steps, making sure that WMP is set to play .mp3 files... yes it is... then i make sure that WMP is set to play the title.mp3 file and set to 'always plays this file using WMP'... yes it is...

So i fire up morrowind again... still the same issue. So what the hell?!

This is where it gets tricky, As i'm on windows Vista, I cannot use the stated fix underneath the inital 'just check its using the right CODEC', as that stated fix is for XP only.

I don't know how t ogo about fixing CODECs, or where i should go to repair my CODECs. This is one of the things (amongst other stuff) i would like advise on.

Since then, the things i HAVE done (still not fixing the problem) are: System restore, complete uninstall and reinstall of morrowind, also deleting all the connected morrowind files in the %AppData% folder before the reinstall, Install the most up to date versions of DirectX, Java, Microsoft .NET, sound card drivers, video card drivers...

Nothing has worked, atall... i'm at a complete loose end and have been racking my brain over it since it happened. I LOVE morrowind, and have had to sacrifice my uberwtfpwn dark elf assassin and ALL the mods i spent months building to work solidly together, not to mention the hours of time i spent getting my character to the point she was at, not to mention my girlfriends sadness at loosing all our work put into the game...

i REALLY REALLY need to sort this out! PLEASE, anyone that can offer any helpfull advise on this matter i ask to please take the time to take in all i have said and reply with any possible fix that could solve this utterly annoying issue.

I await eagerly any reply (i feel sorry for my f5 button :thumbsup:)

All the best. Nomad.

BC AdBot (Login to Remove)

 


#2 Psycho Nomad

Psycho Nomad
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:05:10 AM

Posted 24 February 2009 - 06:05 AM

anyone?

#3 qvcatullus

qvcatullus

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:12:10 AM

Posted 10 March 2009 - 08:19 PM

So, I just got Vista and haven't tried gaming on it yet, so I don't know what's going on for sure. Hooking up to the TV must've changed a default audio setting somewhere. I apologize for not having an answer for you. From what I can tell, Morrowind's extreme pickiness with codecs is a significant problem, and no one seems to be sure of a list of precisely what is causing the problem.
What I recommend is trying the elder scrolls forum at www.elderscrolls.com/forums -- there are some help sections to the forum, including a Vista help section. The guy who made the utility to fix XP problems is registered there as well (check the link to his utility that you quoted for his username there) and might be able to talk about where to get started, although I don't know whether he's still active.

And finally, Morrowind is awesome.

#4 Cuessane

Cuessane

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Silverdale, WA
  • Local time:09:10 PM

Posted 13 March 2009 - 05:35 AM

Not sure if this will work or not, as your problem appears to be a codec error, but it cant hurt to give it a shot. You can try going to http://www.winhelponline.com/articles/105/...dows-Vista.html and getting the MP3 fix that is located there. Its in the boxes, 2nd column from the right, 3rd row down.

Not promising it will work, but I just recently had an error with file associations, and had to use the LNK fix to get my Vista sorted out properly again.

#5 kurac

kurac

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:10 PM

Posted 27 February 2011 - 07:36 AM

I just registered to share with other Morrowind players how I solved this: "music error: cannot play music file. data files/music/special/Morrowind title mp3"

It is due to the new codecs used for audio playback in codec packs such as ffdshow, so i followed this instruction for codec removal:

http://jultech.wordpress.com/2008/09/15/guide-to-a-clean-and-powerful-codec-system/

I haven't installed new codecs yet, but only restored windows default codecs, and Morrowind works perfectly!

Will try with ffdshow latest version + haali splitter, if it doesn't work, i'll just use VLC which has integrated codecs, while I'm playing Morrowind.

#6 troublesh00ter

troublesh00ter

  • Members
  • 561 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Deep South
  • Local time:11:10 PM

Posted 06 April 2011 - 11:31 AM

Hrm... I haven't played morrowind for a long time. That's a classic. I was into modding myself. Whenever something broke I'd get tired of looking for it and just move all my mod content somewhere else, uninstall the game, re-install and move the mod content back.
for3ver,
goose90proof

#7 quazl

quazl

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:10 PM

Posted 21 April 2011 - 08:41 PM

I finally figured it out. I have searched and searched and the fellah who started this topic had the same problem I had.

I followed all the instruction in this post and on Besthesda's forum, and on many mony more forum posts on the web and none of them worked. I am not saying that they do not work, but they did not work for me. I even reinstalled my PC twice during this trouble shoot.

This is the fix if you are using Windows 7 64 bit. At the end of the post is some cool tools to see what is going on in your machine. This is on a completely reinstalled Windows 7 64 bit with the newest updates (04-21-2011). I have not codec pacs at all. I do not have any filters registered (more on the confusion later in the post)

The post above suggested a site that suggested I find Zoom Player and run it Registered Filter Manager. This was the key.

Download Zoom Player (I used Version 7 Professional)
http://www.inmatrix.com/files/zoomplayer_download.shtml

Download regsvrGUI
http://www.softpedia.com/get/System/System-Miscellaneous/Graphical-Interface-to-RegSvr32.shtml

Have Morrowind, all the Expansions, and the most up to date patches installed.

Install Zoom Player (You can use RevoUninstaller Later to Uninstall or Control Panel)

Unzip regshell.zip (this is regsvrGUI all zipped up) to your desktop

Run it

Navigate to C:\windows\sysWOW64\ (you have to double click the folder icons to drill down or up the tree)

On the right panel find quartz.dll

Click Register

Now open Zoom Player and goto Options (control + O)

Swtich to Advanced Mode

Drill Down to System - Filter Management

Click Merit Manager

You will now see a list of all the filters that are registerd on your machine.

Here is the list of Filters that are in quartz.dll

ACM Wrapper
AVI Decompressor
AVI Draw
AVI Splitter
AVI/WAV File Source
Color Space Converter
File Source (Async.)
FIle Source (URL)
FIle Stream Renderer
Internal Script Command Renderer
Line 21 Decode 2
MIDI Parser
MJPEG Decompressor
MPEG Audio Decoder
Mpeg Video Decoder
MPEG-I Stream Splitter
Multi-file Parser
SAMI (CC) Parser
VGA 16 Color Ditherer
Video Mixing Renderer 9
Video Port Manager
Video Renderer
Video Renderer (Yes there are two that are the same)
Wave Parser

The magic Morrowind Filters are ACM Wrapper and MPEG-I Stream Splitter

Info Here:
MSDN

I only add the others so you can remove them if you like a clean system. I use MediaPlayerHometheater and XBMC because I do not like dealing with codecs.

Here is the kicker. VERY IMPORTANT!

If you run Morrowind after running regsvrGUI and then remove all the codecs with the filter manager in Zoom Player except ACM Wrapper and MPEG-I Stream Splitter. It will not work the second time.

IF you want to remove the extraneous filters do it first THEN run Morrowind. Do not ask me why it makes no logical sense. Just don't run Morrowind first. If you want to leave the other filters you are still golden.

That is the fix.

Here is the confustion:

Windows 7 freshly loaded doesn't have any filters but WIndows Media Player 11 and 12 can play files. They must built in like VLC, MediaPlayerHomeTheater or XBMC or I am just ignorant.

If you open up the Morrowind MP3 in graph edit before registering quarz.dll you will see MPEG-I Stream Splitter but no ACM Wrapper. After you register quartz.dll you still do not see ACM Wrapper.

I added ACM wrapper by hand and put it after the MP3 Decode and befoer the default audio driver and it still worked fine.

Wierd.

I really need to learn more about this stuff.

Hope this helps others who just wanted to relax and play some Morrowind

Edited by quazl, 21 April 2011 - 08:44 PM.


#8 Eandyil

Eandyil

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:10 AM

Posted 30 August 2015 - 02:48 PM

Quazl, thank you for that comprehensive guide. I found filter management easy enough, but I didn't see the Merit Manager. That said, I don't care, I tried loading Morrowind from that point and it works! Nothing else I've tried has come close. I'm currently using windows 10, though I upgraded from 7 Pro. So again, THANK YOU!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users