Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

ATI Video Driver = Slow Typing


  • Please log in to reply
7 replies to this topic

#1 Davep785

Davep785

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:04 AM

Posted 22 February 2009 - 10:18 PM

Hello All,
Not very technical, so bear with me.
Had computer for almost 2 yrs, suddenly about a month ago the typing lag in any application became painfully slow, 10 second delay, and then one letter per second after that.
My temporary solution is to disable the video driver by going to Device Manager, under Display adapters goto ATI Radeon Xpress 1150 and choose disable.

How can I download the proper video driver that does not cause slow typing?

I do not use this laptop for gaming, just to type papers for school.

System:
Dell Inspiron 1501
Win XP Media Center Edition

Things I've tried, doesn't fix the problem
I've gone to Dell driver update center.
I've gone http://ati.amd.com/products/catalyst/index.html to download the lates catalyst drivers for my computer.
Tried not loading ati2xxx.exe file at startup when driver was enabled.
Restored my computer to factory settings partition by using Ctrl+F11, loaded the gazillion Windows and Microsoft updates.


The computer screen now look blurry and is a bit hard to read now that I don't have a video driver enabled.

Any assistance you can provide is greatly appreciated.

David

BC AdBot (Login to Remove)

 


#2 Charybdis

Charybdis

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Tasmania
  • Local time:06:04 PM

Posted 22 February 2009 - 10:29 PM

Reinstall the driver as normal then disable the ATI HotKey Poller service in Windows.

click start, then run and type
services.msc
and click ok, now you should see the services list. Find the ATI HotKey Poller Services listing. Right Click on it and select properties. Halfway down the screen you should see the "Startup type." Choose disabled from the drop-down list, click apply, close out all applications and reboot. This should resolve your issues
(thanks to marcolian)

#3 Davep785

Davep785
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:04 AM

Posted 22 February 2009 - 10:42 PM

Thank you Charybdis and marcolian. Worked very well.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,567 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:04 AM

Posted 23 February 2009 - 02:43 PM

Nicely done :thumbsup: .

Louis

#5 ibrahim52

ibrahim52

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:04 AM

Posted 13 May 2009 - 01:49 PM

I dont know who you are Charybdis or i should say my solution provider.But i tell you one thing,this is the most genius solution i ever had.I formatted my clients pc for like two times plus i tried to install the latest version of drivers,but couldnt resolve it.My google search brought me here and my problem was exactly the same and you resolved it in a very easy manner.I am surprised and happy.I registered to this forum specially just to say THANK YOU.THANK YOU very much for saving my day ,time and my name towards my clients.Sorry for my bad grammar.thanks once again.

#6 Sewingirl

Sewingirl

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:04 AM

Posted 11 June 2009 - 04:26 PM

I have the same problem on my Dell Inspiron 1501. I spent most of the day yesterday reformatting the hard drive. It seemed to work until I loaded the drivers. Then i came across this posting and noticed that the Display adapter has ATI Radeon Xpress 1150. I followed your instructions and uninstalled the driver, then i disabled ATI HotKey Poller Service. I rebooted and the darn ATI Radeon Xpress driver is running again and causing the slow typing again. As long as the Driver is uninstalled, there is fast typing and no delay. when i shut down and reboot, the driver reinstalls itself and the delay begins. Please advise me on how to stop this driver from reinstalling itself. ALso, i would like to know what this driver is used for and why i do not need it. Do i need to reinstall another type of Display adapter? Thanks.

Edited by Sewingirl, 11 June 2009 - 04:26 PM.


#7 ravensdude

ravensdude

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:04:04 AM

Posted 29 June 2009 - 11:22 PM

Had the same problem with my Mom's Dell Inspiron 1501. Being the family computer guy I was a little angry when I could not figure this out. Tried almost everything and was just about completely stumpped. Ended up google searching my problem and found this site. What a life saver and such a simple fix lol. Thanks a lot man. :thumbsup:

#8 opala

opala

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:04 AM

Posted 07 October 2009 - 10:03 AM

looks like nobody noticed second part of this problem (another possible solution)...
when battery is out of notebook slow typing problem disappears ...
:flowers:
battery inside + ATI HotKey Poller Service = problem

thanks for this solution - worked for me like a charm
:thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users