Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

digicam driver problem


  • Please log in to reply
9 replies to this topic

#1 chevyusa1

chevyusa1

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Local time:03:14 PM

Posted 01 June 2005 - 10:54 PM

I'm having problems with a new digicam that I got as a gift. It is new and was in the box but came without any software/drivers. The company name on the box is "PREMIUM™". Searches on the net have yielded nothing for this company. there is a model number on the box also, "DC2130". Google searches for this model number have resulted in various site where I can buy this cam (or one like it) but no links for drivers or software can be found. It is a very basic and cheap cam but there are pics on it that I would like to retrieve. Thanks for any input you may have. :thumbsup:

BC AdBot (Login to Remove)

 


#2 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:06:14 AM

Posted 03 June 2005 - 12:53 AM

Is this it?

http://www.bond.co.id/dc2130_package.htm

most of the links on that page didn't work for me but there is an email addy, you might get lucky. Did your friends pass through Indonesia recently?

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#3 chevyusa1

chevyusa1
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Local time:03:14 PM

Posted 04 June 2005 - 09:43 PM

thanks for the response Rimmer. :thumbsup:
I found that site also, but the links didn't work for me either.
The cam actually came from "selectyourgifts.com". I had recently visited a "Tent Sale" for used cars and I won a $250.00 gift certificate at that site and the cam was like $15.00 or something so I got it. I have since revisited the site but with no response from them. Soooo, here I am. Is Indonesia where the cam is made?
Thanks again! :flowers:

#4 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:06:14 AM

Posted 04 June 2005 - 10:30 PM

Is Indonesia where the cam is made?


It appears so.

Try emailing them and asking for a link to a Driver download.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#5 chevyusa1

chevyusa1
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Local time:03:14 PM

Posted 05 June 2005 - 10:50 PM

I sent an email to them but no joy as far as any response, yet.
The cam pictured at http://www.bond.co.id/dc2130_package.htm
looks like my cam except that mine has no letters or numbers anywhere on the cam itself, but it has the same base and USB cable and all that. I got the model # off of the box it came in. i'm not even sure that "Bond" is the manufacturer of my cam. Thanks again! :thumbsup:

#6 chevyusa1

chevyusa1
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Local time:03:14 PM

Posted 08 June 2005 - 11:26 AM

Rimmer, I actually got a response from BondIntel requesting my mailing address so that they can send me the software! I hope it works, like I said before, the Bond DC2130 looks like my cam but mine doesn't say "Bond" anywhere on it. I'll add a reply to this post after I install the software, just to let everyone know if this solves my problem or not. But I'm not sure how long it will take to recieve the CD from Bond. Thanks again Rimmer!

#7 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:06:14 AM

Posted 08 June 2005 - 07:37 PM

Sounds like progress! :thumbsup:

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#8 chevyusa1

chevyusa1
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Local time:03:14 PM

Posted 14 June 2005 - 10:24 AM

Here's an update on my situation. As posted before I got a reply from Bond asking for my mailing address so they can send me the CD with drivers, I sent them my address, then I get a reply stating that I can download the drivers from the website, WRONG. The links at the website DO NOT WORK. So I replied to their email and told them that the links do not work and I reminded them that THEY said in THEIR email to me that they would SEND me the drivers via postal mail. I doubt that I will get the help from them. I find it hard to believe that no-one else has this cam or knows where to get the drivers. Maybe I will just trash the piece of junk! Thanks for your help Rimmer! My advice to anyone looking for a digicam is to stear clear of BONDINTEL!!!

Edited by chevyusa1, 14 June 2005 - 10:25 AM.


#9 chevyusa1

chevyusa1
  • Topic Starter

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Local time:03:14 PM

Posted 16 June 2005 - 11:49 AM

This is unbelievable! In my last email to the person at Bondintel, I requested that they send me the Link for the drivers since the Links at the website don't work. Well they did and guess what?????.......... Hotmail BLOCKED the attachment because it had a virus!!! What the HECK is the problem with this company? They must be crooks! Or they HATE Americans. Not only do they seem to not want to help but now trying to send me viruses. I will be sending the emails that I recieved from Bondintel to Cert and am also considering reporting them to my local athorities as well as the athorities in Indonesia.
A warning to ALL: AVOID THIS COMPANY--BONDINTEL

#10 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:06:14 AM

Posted 16 June 2005 - 07:55 PM

Sorry your having such a tough time with this - it should be a simple matter. It sounds to me like they're just incompetent. :thumbsup:

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users