Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

VLC opening ALL other programs


  • Please log in to reply
3 replies to this topic

#1 Thane

Thane

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:48 PM

Posted 15 February 2009 - 09:50 AM

Hi All,

OS: XP Pro

I have an external drive where I have several programs installed to keep my laptop empty of those programs I do not use very often. One of those, VLC, was pinned to the Start Menu. For whatever reason, the drive letter to the external drive was changed, so I had to browse for the VLC program again. However, I didn't notice the "Always use the selected program to open this kind of file" was checked when I did so.

Every *.exe file is now associated with VLC.

I can right-click & choose "Open" & the exe's will run normally. However, if I just click, for example, Excel, VLC opens instead. When I right-click on "My Computer" & select properties, the same thing happens.

The first item of the right-click menu is "Play with VLC". I think that is part of the issue(?), but have no idea how to correct it.

Another sticky widget is this: in the "Tools/Folder Options - File types", my *.bin files seem to be associated with VLC as well. At least, VLC's icon is next to 'BIN' in the list. Is this perhaps part of the same issue?

Files will open normally. In other words, if I click a Word document, Word will open it, not VLC. It's only the executables I'm having issues with.

It's not a big deal since everything in genereal runs as it should, but it's certainly an itch I'd like to stop scratching.

Thanks in advance for your advice,
Thane

Edited by Thane, 15 February 2009 - 10:02 AM.


BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:48 PM

Posted 15 February 2009 - 08:37 PM

In Windows Explorer go Tools > Folder Options > File Types tab. You should be able to delete any associations that you don't want from there.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 Thane

Thane
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:48 PM

Posted 20 February 2009 - 08:12 AM

Thanks for the tip, but that's not it.

It's not files that are being opened by VLC. It's the programs themselves. There's a huge difference. a *.doc or *.xls files will open the appropriate executable (Word or Excel). When I choose the actual program Word or Excel, VLC opens instead.

To make it clearer~

Excel is in my Start Menu. I click the icon. VLC MEdia Player opens instead. (This happens when I go to the MS Office folder & try to open the program there.)

There's an Excel file in My Recent Documents. I click it & Excel opens up the file. It displays properly.

So again, it's not the files I'm having trouble with.

The Bin thing in my first post is a red herring. Ignore that.

#4 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,579 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:48 PM

Posted 20 February 2009 - 05:29 PM

Did you check if .exe files are associated with VLC in Folder options.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users