Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Toshiba Laptop HD connector


  • Please log in to reply
1 reply to this topic

#1 jgadrummer

jgadrummer

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:11:09 PM

Posted 11 February 2009 - 12:07 PM

I have a Toshiba Satellite M305D - S4830 laptop. The HD part# is MK2552GSX. I sent the old HD to Toshiba since it was still under warranty and they sent me a new one (only a month later, grin) Anyway, I guess I left the sata connector on the old one which they refused to send back and I have tried atleast a dozen times to find one. Both ends, the HD side and the mother board side are SATA but when you put the HD in the caddy and slide it into place there is a gap between the drive and motherboard. See attached photos...

Any help would be great, its a new laptop that is wasted because of this.

Thanks


Jga

Attached Files

  • Attached File  hd1.jpg   21.4KB   6 downloads
  • Attached File  hd2.jpg   25.64KB   7 downloads
  • Attached File  hd3.jpg   26.43KB   8 downloads
  • Attached File  hd4.jpg   15.04KB   8 downloads
  • Attached File  hd5.jpg   23.29KB   7 downloads

"All the world's indeed a stage and we are merely players..."
'NP'

'Music is the fuel of life...'

BC AdBot (Login to Remove)

 


#2 the_patriot11

the_patriot11

    High Tech Redneck


  • BC Advisor
  • 6,759 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wyoming USA
  • Local time:09:09 PM

Posted 12 February 2009 - 02:35 AM

Id call toshiba customer service, they should know where to get the part if their worth half what they get paid.

picard5.jpg

 

Primary system: Motherboard: ASUS M4A89GTD PRO/USB3, Processor: AMD Phenom II x4 945, Memory: 16 gigs of Patriot G2 DDR3 1600, Video: AMD Sapphire Nitro R9 380, Storage: 1 WD 500 gig HD, 1 Hitachi 500 gig HD, and Power supply: Coolermaster 750 watt, OS: Windows 10 64 bit. 

Media Center: Motherboard: Gigabyte mp61p-S3, Processor: AMD Athlon 64 x2 6000+, Memory: 6 gigs Patriot DDR2 800, Video: Gigabyte GeForce GT730, Storage: 500 gig Hitachi, PSU: Seasonic M1211 620W full modular, OS: Windows 10.

If I don't reply within 24 hours of your reply, feel free to send me a pm.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users