Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I Fixed my Broken System Restore. Yipee!


  • Please log in to reply
1 reply to this topic

#1 buttoni

buttoni

  • Members
  • 267 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Temple, Texas
  • Local time:09:27 PM

Posted 08 February 2009 - 10:41 AM

I'm so proud of myself and thought I'd share a useful fix. For about 4 months now, my System Restore has not been fully working properly. Not sure exactly what broke it. Maybe a power outage, improper shutdown or file corruption. Dunno. It was creating System Checkpoints I could see on the SR calendar. It would manually create restore points for me. But every time I'd try to system restore to an earlier date, I'd get an error saying "Unable to restore to the earlier date. System was not restored. Select another date." (or something to that effect). But selecting every date on the calendar would result in the same error. Grrrrr! Backing up to an older ERUNT registry wasn't really an option, because I didn't know how far back to go without messing things up & undoing huge amounts of Windows updates/patches/new installs/uninstalls.

Started researching on this and other tech forums, as well as Googling and found this possible fix.

http://bertk.mvps.org/html/reinstall.html

I first did a backup of my (all-users) registry using ERUNT (just in case my experiment damaged my system further) and a scannow to be sure system files on my HDD were all OK. I reinstalled System Restore per the directions at the above link. I did have to navigate to a couple of the files needed during that process. But once all steps completed, it said it had reinstalled System Restore & I got no errors whatsoever. Note*******that doing this wipes out all prior restore points! It appears to have created one when done, but not knowing this, I created one OK myself. Then I waited one day and tried a manual restore to the day before and IT WORKED!!!!!

Hope this link proves useful to others as well.

Edited by buttoni, 08 February 2009 - 10:51 AM.

HP Pavilion desktop p6270z; 8 GB ram; Win7 Home Premium x64 bit; FX 4.0; DSL 2Wire modem/router; MVPS Hosts; Comodo FW 5.3(D+ & Sandbox enabled); MSSE; MBAM on demand.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:10:27 PM

Posted 08 February 2009 - 11:42 AM

Thank you for sharing your fix
Glad you got it working
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users