Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wordpad document was saved as a MS-DOS Application.


  • Please log in to reply
6 replies to this topic

#1 1up2down

1up2down

  • Members
  • 284 posts
  • OFFLINE
  •  
  • Local time:10:07 AM

Posted 08 February 2009 - 08:25 AM

Why is it that when I saved a Wordpad document, it automatically saved it as a MS-DOS Application which Windows says it can't open, and is there any way I can I open it. It took me literally hours to write everything down, and even if I could remember every word, I don't want to spend all that time writing it out again. I would appreciate any advice you can give me.

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,551 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:08:07 AM

Posted 08 February 2009 - 10:56 AM

Well...first of all...no document file can be saved as an application (and expect to work).

A Wordpad document should be saved as a text file, with a file extension of .txt. It can never be saved (and expected to function properly) as a file with an .exe ending, since those are programs, not documents.

What is the full filename (file + extension)?

Example: I have a file titled List, which I create in Wordpad. When I save it, it will appear as List.txt in whichever location I choose to save it.

I guess I have to wonder...where did you get the idea that you created a file and saved it as an MS-DOS application? Did you get an onscreen message stating such?

What was the exact message you received from Windows when you created this wordpad file?

Louis

#3 theungod

theungod

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:09:07 AM

Posted 08 February 2009 - 11:02 AM

Right click on your file, and choose "Open With..." and then select Wordpad from the list of programs. If that doesn't work you have to change the filename extension, by opening up the folder its in and going to Tools>Folder Options. Then under the "View" tab, uncheck "Hide extension for known file types." Then click Apply and OK. Now you can change the extension of the filename to ".rtf" or ".txt" and it should open in Wordpad.

#4 1up2down

1up2down
  • Topic Starter

  • Members
  • 284 posts
  • OFFLINE
  •  
  • Local time:10:07 AM

Posted 08 February 2009 - 11:52 AM

Well...first of all...no document file can be saved as an application (and expect to work).

A Wordpad document should be saved as a text file, with a file extension of .txt. It can never be saved (and expected to function properly) as a file with an .exe ending, since those are programs, not documents.

What is the full filename (file + extension)?

Example: I have a file titled List, which I create in Wordpad. When I save it, it will appear as List.txt in whichever location I choose to save it.

I guess I have to wonder...where did you get the idea that you created a file and saved it as an MS-DOS application? Did you get an onscreen message stating such?

What was the exact message you received from Windows when you created this wordpad file?

Louis



Hi Louis
I never really pay a lot of attention to the save as type box. Just put in the filename and click save. Normally it saves it as a Rich Text Document on the desktop which appears like a note book. In this case it still saved it to the desktop but appears a bit like the Wordpad document does when it's open only smaller, a white rectangle with a blue bar across the top.

No message was given when it was created, but when you try to open it, a black rectangle box with blue bar appears with nothing on it but the filename I gave it. When I try to close this box I get the message, Windows cannot end this program.

This has only happened the once and all other Wordpad documents have saved normally
Tony

#5 1up2down

1up2down
  • Topic Starter

  • Members
  • 284 posts
  • OFFLINE
  •  
  • Local time:10:07 AM

Posted 08 February 2009 - 11:56 AM

Right click on your file, and choose "Open With..." and then select Wordpad from the list of programs. If that doesn't work you have to change the filename extension, by opening up the folder its in and going to Tools>Folder Options. Then under the "View" tab, uncheck "Hide extension for known file types." Then click Apply and OK. Now you can change the extension of the filename to ".rtf" or ".txt" and it should open in Wordpad.


I have tried right clicking it, but there is no (open with) there to select. I also followed you other instructions but could not see any extension to change. However, I right clicked it and selected properties. In the properties box under program, I selected Advanced. This opened a box showing a Autoexec filename %SystemRoot%\SYSTEM32\AUTOEXEC.NT and a Config filename %SystemRoot%\SYSTEM32\CONFIG.NT will changing either of these do any good?


Tools>Folder Options. Then under the "View" tab, uncheck "Hide extension for known file types." Then click Apply and OK. Now you can change the extension of the filename to ".rtf" or ".txt" and it should open in Wordpad.

#6 theungod

theungod

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:09:07 AM

Posted 08 February 2009 - 12:28 PM

Not sure changing those properties would do any good. Odd there'd be no extension to change, it would probably be .exe or .bat and you would change it over to .rtf. But try this at least to get your work back.

Open up Wordpad, and then go to File>Open and in the 'files of type' drop down box, select "All Documents (*.*)", then navigate to the file and try opening it that way.

#7 1up2down

1up2down
  • Topic Starter

  • Members
  • 284 posts
  • OFFLINE
  •  
  • Local time:10:07 AM

Posted 08 February 2009 - 12:57 PM

Not sure changing those properties would do any good. Odd there'd be no extension to change, it would probably be .exe or .bat and you would change it over to .rtf. But try this at least to get your work back.

Open up Wordpad, and then go to File>Open and in the 'files of type' drop down box, select "All Documents (*.*)", then navigate to the file and try opening it that way.


Hey, thanks a lot. That trick worked and saved me a lot of work. :thumbsup:




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Bing (1)