Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

XP Pro - D3D problems


  • Please log in to reply
2 replies to this topic

#1 macwa

macwa

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:33 AM

Posted 06 February 2009 - 12:41 PM

Hello,

since upgrading my computer's hardware (new mainboard and graphicscard), and re-installing windows, it appears I am unable to play any game.
I've tried Ghost Recon: Advanced Warfighter, Splinter Cell: Double Agent, Hitman: Blood Money.
All install fine, but, once started, almost instantly crash to desktop.

Running DXDiag shows DirectDraw works fine, but the Direct 3D test for D3D 7, 8 and 9 all fail.
Graphicscard is an ATI FireGL 5600.
DirectX version 9.0C is installed
I've attached the dxdiag log.

Any help getting my games working again would be greatly apreciated

Attached Files


Edited by macwa, 06 February 2009 - 12:48 PM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,086 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:33 PM

Posted 06 February 2009 - 01:02 PM

Hi :thumbsup:.

Did you try the card on a different system?

Have you checked Event Viewer for possible clues?

How To Use Event Viewer - http://www.bleepingcomputer.com/forums/t/40108/how-to-use-event-viewer/

Louis

#3 hellknight

hellknight

  • Members
  • 120 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Netherlands
  • Local time:12:33 AM

Posted 06 February 2009 - 01:26 PM

Greetings Hamluis,

to avoid confusion - I'm a friend of Macwa's, and am trying to help her get the problem resolved - no luck so far.
I'm a bit more tech-savy then she is, so some answers might come from me, instead of Macwa.

I've checked eventviewer - nothing special there.
We've tried re-installing the drivers - no luck.

When GRAW crashes, it generates the following error:

Crash in application version: grpcrc1.02

Failed setting up render device.


We haven't checked the card in another pc, since the only other system available is a laptop.
However, I doubt the issue is a defect of the card - I'd expect BSOD's, graphical problems, etc - not just games CTD'ing




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users