Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

IE7 seems to think I'm in Germany, not U.S.


  • Please log in to reply
10 replies to this topic

#1 pogodog

pogodog

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:21 AM

Posted 26 January 2009 - 09:38 PM

I live in the U.S.A. I got a new mouse about two weeks ago. When I hooked it up, I also took the opportunity to shut my PC down, disconnect all the peripherals, move it a few feet, vacuum the dust off the fan vents, etc. When I started it back up (with the new mouse installed) and opened Internet Explorer and went to Google, it displayed the German language version of the Google home page. I went into the Google preferences page and changed it back to English. Then I went to my Internet banking site, and when I went to login, it told me it didn't recognize the computer I was logging in from, and gave me one of my challenge questions (the next day, the Internet Security department from my bank called me and said their records showed my login had come from Germany). Then I went to the Travelocity website and it gave me some sort of welcome page that indicated I was out of the country.

I've previously loaded Malware Bytes and Super Anti Spyware on my computer, and also have NAV, and have run all of those, so I don't think it's virus or botnet related, though that thought has crossed my mind. Is there some setting in IE7 that has changed, that I can change back?

I've looked at Tools>Internet Options>Languages, and US English is the only language listed. I also looked at About Internet Explorer>System Info and there is nothing out of the ordinary (no proxies active, etc.).

When I do a Google search now, for example - it displays the results in English, but the sponsored ads over on the right side of the page are all for German websites.

I have restarted the computer a couple of times since then, but am still getting the same results. I'm running XP, and the browser is IE7. Any help would be greatly appreciated!

BC AdBot (Login to Remove)

 


#2 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:11:21 AM

Posted 26 January 2009 - 11:12 PM

This is for XP.

Start Menu/Control Panel.
Regional and Language Options.

Regional Options tab.
At the bottom, check your location. If it does not say United States, click the drop down arrow and change it.

Click APPLY to save the change.

#3 pogodog

pogodog
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:21 AM

Posted 26 January 2009 - 11:42 PM

Tried that and it was set for United States. I'm wondering if it might have something to do with my IP address; Google's page said something about how it loads the ads based on your recent browsing history and your location based on your IP address. I've disconnected my network connection to see if I can pick up a different IP address from my ISP but I keep getting the same one. Any suggestions on how to force my connection to pick up a new IP address?

#4 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:11:21 AM

Posted 27 January 2009 - 12:09 AM

Forcing a new IP address is out of my league. Someone else will have to explain that.
Sometimes there is a simple solution-in your case simple didn't work.

#5 Gstick

Gstick

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:12:21 PM

Posted 27 January 2009 - 06:51 AM

See the Google article below, it may help you. For now, bookmark the page www.google.com/webhp or www.google.com/ncr
The ncr stands for No Country Redirect. This will ensure access to google.com

http://www.google.com/support/websearch/bi...r.py?answer=873

"I'm not dumb. I just have a command of thoroughly useless information."


#6 I don't know

I don't know

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Location:Rochester, NY
  • Local time:11:21 AM

Posted 27 January 2009 - 08:25 AM

To force a completely new IP address, go to Start-->Run, type in cmd and your command window should open. Type in ipconfig /all which should display your current IP address. Next type in ipconfig /release which should release your current IP address. Type in ipconfig /renew to get a new IP address and then check that you got the new address by typing in ipconfig /all .

#7 DoesNotCompute

DoesNotCompute

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Washington D.C.
  • Local time:11:21 AM

Posted 27 January 2009 - 08:46 AM

The previously posted instructions for and IP release are for your local IP address on the LAN (Intranet) not your external IP address that is seen over the WAN (Internet). This should have no change on how external sites see you IP address. To achieve a change of your public IP address you would have to release it and renew it from your ISP through the modem. The exact steps for this would depend on your brand of modem, which you should be able to Google up the manual. However, this does not seem to be the cause of your problem (at least to me). Your bank would be monitoring the IP address from which your requests are coming from which would be the public address and from a residence in the U.S. should be a 68.xx.xx.xx I believe. It seems you may want to first check your host file C:\WINDOWS\system32\drivers\etc and make sure there are no suspicious entries which may be redirecting your outgoing requests. The next step would be to contact your ISP and inform them of this issue. I would be cautious that you are not having a hijacking issue of some type. The main reason being the Bank problem not the language display issues. One last note: Are you sure that it was indeed your Bank that had called you? Did they ask for any personal info? Did you install any software that came with the mouse? Did you register anything that came with the mouse including your phone number? I would call your banks number back (make sure you definitely have their correct #) if you are unsure about any of these questions. This may be blowing your issue out of proportion but better safe than sorry! I am very intrigued about your issue . . .

#8 lhamil64

lhamil64

  • Members
  • 200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:12:21 PM

Posted 27 January 2009 - 11:20 AM

I'm not sure what could be causing it but it kind of sounds like you are somehow connecting through a proxy or something. Did anyone have access to your computer without you seeing what they were doing?

#9 InterestinglyAverage

InterestinglyAverage

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States
  • Local time:12:21 PM

Posted 27 January 2009 - 11:30 AM

If several web sites are all showing that you are in Germany, I am most inclined to believe that the problem is that your traffic is being routed through a proxy of some sort. It is unlikely that numerous sources are misidentifying your IP address, as they all pull from different databases, and they should be relatively accurate, especially Google.

First, a few questions that might help narrow down the troubleshooting. 1. Is the computer connected directly to the Internet, or is there a router? If there is a router, what brand is it? 2. Do you have other computers on the same network as this computer, and if yes, do they have the same issue? 3. Do you have alternative browsers (Firefox, Opera, etc) installed on the computer?

Based on your answers to these questions, I should be able to suggest some troubleshooting steps to identify and hopefully correct the problem.

You might also want to try uninstalling all the software that came with the mouse, since that is when the problem started. However, if you don't often reboot your computer, that could be coincidence.
The only way to learn anything is to question everything.

#10 karbo1

karbo1

  • Members
  • 172 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Quebec, Canada
  • Local time:11:21 AM

Posted 27 January 2009 - 12:19 PM

A simple first step to know if you're behind a proxy server is to check into your IE7 options. Under the Connections tab, click on Network settings. Is Proxy server checked? But if you were behind a proxy server, your browsing speed would be slower, unless perhaps it were a paid proxy server. The other funny thing is that a free proxy server never lasts for too long. A day or two, then you have to find another one. I'm puzzled.

Edited by karbo1, 27 January 2009 - 12:27 PM.

Please post back if we found the solution

#11 karbo1

karbo1

  • Members
  • 172 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Quebec, Canada
  • Local time:11:21 AM

Posted 29 January 2009 - 12:18 PM

If you go here, what country shows up?

Edited by karbo1, 29 January 2009 - 12:19 PM.

Please post back if we found the solution




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users