Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

rpc issue, freezing issue, networking issue... help


  • Please log in to reply
1 reply to this topic

#1 gravity_fighter

gravity_fighter

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:06 PM

Posted 18 January 2009 - 11:28 PM

Ok, I've checked a bunch of sites and seen people with similar issues, but none have exactly the same problems I'm having. I have Windows XP and frequently used ZoneAlarm, Spybot, Adaware and Spywareblaster. HJT did not solve this problem for me.

My computer:
freezes at the log in 80% of the time unless I login in safe mode
if I'm able to log in, safe mode or not, I get a RPC error that says the PC will shut down in 60 seconds 100% of the time
I cannot run/install antivirus because I get a "not a valid win32 application" message
cannot connect to wireless connection and shows error message when the wireless adapter loads (there's a spot for it next to the clock, but the icon's invisible)
sometimes reboots randomly without the win32 app message
sometimes goes to a black screen and then comes back, then showing a "system has recovered from a serious error, please tell Microsoft" message
shows a blue screen at startup saying win32/autocheck didn't work, then finishes startup through the login screen
cannot system restore because no restore points are visible before infection


So far, I've been able to keep the PC running in safe mode occasionally thanks to Run>shutdown -a. The disc drives weren't reading for awhile but I've gotten those to load again. I tried to uninstall my wireless adapter to reinstall, but I get an error message "InstallShield Engine (iKernel.exe) could not be launched. The RPC server is unavailable." I'm pretty sure I already disabled the RPC 5 years ago, so I'm wondering how this is even a problem.

I managed to successfully run HJT once, and it didn't do much for me. Since I don't have networking, I can't transfer my HJT log to this post, but I can ID every file except
O4 - HKLM ... \Run: [KernelFaultCheck] % systemroot %\system32\dumprep 0 -k

I'm pretty much out of ideas on how to fix this and could really use some help. I tried to install the patch for w32 blaster worm and it's not a valid application. I tried Symantec's removal tool and it said that worm is not found on the system. So the only thing I know for certain is that it's not w32 blaster, or at least the SAME w32 blaster.

Any help would be much appreciated.

Edited by gravity_fighter, 18 January 2009 - 11:30 PM.


BC AdBot (Login to Remove)

 


#2 lowtek_otc

lowtek_otc

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Local time:07:06 PM

Posted 19 January 2009 - 12:30 AM

Oh boy, that is a lot of issues, it would most likely take less time and effort if you just backed up your data and do a full wipe and reformat.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users