Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer not detecting/recognizing usb device


  • Please log in to reply
7 replies to this topic

#1 clairex3

clairex3

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:NJ
  • Local time:11:15 AM

Posted 17 January 2009 - 04:38 PM

I have a very simple usb flash drive, 8gb and my laptop and sister's computer both recognize it.
It used to work on this computer as well BEFORE I sent it to a computer place to get fixed.
So now it doesn't work and I'm almost positive that it's safe to say that the usb is not faulty.
And in device manager the only thing with the yellow question mark is my printer, which probably wouldn't affect my usb.
So any answers or links would be greatly appreciated (:

BC AdBot (Login to Remove)

 


#2 Boneshaker

Boneshaker

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:15 AM

Posted 18 January 2009 - 12:19 AM

You mentioned "sent it to a computer place to get fixed" ...

What did they fix?
A woman is an occasional pleasure but a cigar is always a smoke ... Groucho Marx

#3 clairex3

clairex3
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:NJ
  • Local time:11:15 AM

Posted 18 January 2009 - 01:42 AM

There was a virus and it was reformatted.
But, I checked the drivers, and like I said the only thing with the yellow (?) was the printer
(:

#4 madeupfile

madeupfile

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:11:15 AM

Posted 18 January 2009 - 02:46 AM

i have the same EXACT problem not sure if they reformatted or not but my mp3 player which connects also to my computer to charge and obviously to add files only charges and no drive shows up

Edited by madeupfile, 18 January 2009 - 02:49 AM.


#5 Boneshaker

Boneshaker

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:15 AM

Posted 19 January 2009 - 12:26 AM

The USB drive may be being assigned a drive letter that is already assigned to another drive. This is assuming that the USB drive is found by the computer but not assigning it a drive letter. If the USB drive is not found, then there probably is a hardware or driver problem.

Go to the "my computer" icon on your desktop and right click ... Select "manage" ... On the left side of the window you'll see "Disk Management", click it ... At the bottom of the right pane you should see your usb drive listed ... If you do see it there. Right click it and select "Change Drive Letter and Paths" ... Click "change" and then click the little arrow button to select a new drive letter ... click "Okay" and "yes" and you're done.

Hope this helps

Edited by Boneshaker, 19 January 2009 - 12:27 AM.

A woman is an occasional pleasure but a cigar is always a smoke ... Groucho Marx

#6 madeupfile

madeupfile

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:11:15 AM

Posted 19 January 2009 - 01:12 AM

sry

Edited by madeupfile, 19 January 2009 - 02:19 PM.


#7 clairex3

clairex3
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:NJ
  • Local time:11:15 AM

Posted 19 January 2009 - 05:48 PM

It didn't really change anything unless I did something wrong.

You said if I do not see it there then right click.
Right click where?

#8 clairex3

clairex3
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:NJ
  • Local time:11:15 AM

Posted 19 January 2009 - 06:12 PM

The problems fixed
I did the following:

Try this fix for missing usb ports by JohnWill

Create a file with NOTEPAD containing the following lines and save it as FIX.REG
-------------------------- Use text after this line --------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
-------------------------- Use text before this line --------------------------------

Double click on FIX.REG and say yes to the Merge Into Registry question.

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives that you know are not present.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.

NOTE: If you have a USB keyboard and/or mouse, you'll have to modify the instructions and leave enough parts for those to function. I don't have one yet, so I haven't had time to modify the instructions.

Which I found here: http://forums.techguy.org/hardware/580686-...g-external.html

(I had a usb mouse so I just switched my mouse from another cmoputer and it worked)

EDIT // now it's not working again ...
EDIT 2// it works not, a bit trippy but it works. sometimes i have to unplug and replug. but it still works. hope it works for others coming across this forum :thumbsup:

Edited by clairex3, 19 January 2009 - 06:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users