Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Google Desktop fails to launch


  • Please log in to reply
1 reply to this topic

#1 oscarlate

oscarlate

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:03 AM

Posted 14 January 2009 - 11:38 PM

google desktop begins to run (it appears in my process explorer) but
before it properly initialises, it shuts down for some reason. No
screen appears telling me error anything, and it doesn't get activated
far enough to show the search bar (which is all i have set to appear,
usually).

I've also got it set to run from startup, but that obviously isn't
working, either. No icon appears in the taskbar.

I've tried uninstalling and reinstalling, but the problem remained. I
tried exploring my computer's security settings, thinking that maybe
it had been blocked, but that doesn't appear to be the case. Not as
far as I can tell, anyway.

I tried turning off the firewall, but that didn't change anything
either.

I'm pretty sure it was working yesterday. The only changes i can think
of that have been made to my computer are...

a few new firefox add-ons (greasemonkey and stylish), and java
recently updated.

Outlook is also crashing but that might not be related.

screenshots:
http://forpeeps.airpost.net/public/gd%20launch.JPG
http://forpeeps.airpost.net/public/gd%20fail.JPG

immediately after this, google desktop disappears from the process
tree.

BC AdBot (Login to Remove)

 


#2 oscarlate

oscarlate
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:03 AM

Posted 09 February 2009 - 06:52 PM

so i worked it out.

I guess, whenever NOBODY answers, it means NOBODY is having the same
problem, which means it is much more likely something i've done, than
something the program has done.

in this instance that turns out to be the case.

in january, somehow (don't ask me how) i managed to mark everything
in-

C:\Documents and Settings\*USER*\Local Settings\Application Data\

as read only.

That meant that Google Desktop (and Outlook) could not access it's
database. I suppose in an ideal world google desktop would tell me,
"you idiot, you made my database read only and now i can't run", and
I'd be able to fix it. instead it just wouldn't run.

So. Messing around again today, this time trying to get Outlook to
start (I really should have addressed that problem earlier but I just
hate that program and was kinda happy to have a reason not to use it),
and taking my lead from this guide:

http://www.insideoe.com/problems/errors.htm#foldersdbx

I realised Outlook's databases were marked read only. I cleared the
read only checkbox on their folder and it launched. SO then i figured
it might be the same problem with google. It was.

If you think you've made a similar mistake, here's how I fixed it.

Go to C:\Documents and Settings\*your windows user name*\Local Settings
\Application Data\Google\

right click on the folder "Google Desktop", select "Properties",
uncheck "Read Only". A dialogue box should appear that reads:

Confirm Attribute Changes

"You have chosen to make the following changes:

unset read-only

Do you want to apply this change to this folder only, or do you want
to apply it to all subfolders and files as well?"

Make sure the radio button by

"Apply changes to this folder, subfolders and files"

is selected, hit apply, hit ok.

Google desktop should launch now. and take a good while to index all
the files you've created while it hasn't been able to get in :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users