Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Restore Normal Keyboard Accessibility Option


  • Please log in to reply
6 replies to this topic

#1 rickblee

rickblee

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:08:45 PM

Posted 23 May 2005 - 10:24 AM

Problem: My Windows 2000 Professional (version 5.0) will not respond to my Logitech Easy Internet Keyboard.

History: I "rested" my finger on my right shift key for several seconds (mindlessly). This caused a window to pop up asking if I wanted to activate the FilterKeys, a feature of the Accessibility Options. It also gave me a check box to mark if I did not want to repeatedly bring up this option each time I held down the right shift key for too long.

I clicked the check box and now my keyboard doesn't get through to the
CPU at all. Very frustrating.

My wireless mouse continues to work fine.

I went to Windows 2000 help and clicked Troubleshoot on my Keyboard options. I can't follow any of the proposed fixes because of the disconnect between my keyboard and my CPU.

1. Help recognizes that I may have trouble "logging back on to your computer after activating FilterKeys."

2. It cautions that the solution "may require editing your Windows 2000 registry." Dangerous. And I've never done it before.

3. It says I will have to edit the registry from another computer. (I have a laptop running Windows XP. Yea.)

or Edit it from a second copy of Windows 2000 on my hard disk. (As far as I know I don't have that.)

4. It suggests I can enable automatic logon after using one of these processes.

5. It also suggests I may have to reinstall Windows 2000 as a solution.

6. Either solution using my Windows 2000 requires that I use the keyboard (to login, change user to Administrator and type in a password.

7. I don't know how to edit my registry in my 2000 from my XP.

How do I get my keyboard communicating with my CPU again?

By the way I am currently in Brazil. It will be tough to find a computer tech in my small town. It will be tougher to find one that speaks English. So, any help this community can give will be much appreciated. Thanks.

Rickblee

BC AdBot (Login to Remove)

 


#2 Herk

Herk

  • Members
  • 1,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:S.E. Idaho, USA
  • Local time:09:45 PM

Posted 23 May 2005 - 10:35 AM

Can you simply go to Accessibility Options in the Control Panel (using the mouse), then reset the keyboard from there, or under the General Tab have it turn off the accessibility features after a preset time? While you're at it, uncheck the "Use Shortcut" setting in the filterkeys settings.

#3 rickblee

rickblee
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:08:45 PM

Posted 23 May 2005 - 12:48 PM

Good ideas, all. But they did not get me the results.

I saw no place in Accessibility Options to reset the keyboard.

At your suggestion, I unchecked the shortcut option and I selected the 5 min preset time option. After five minutes of not touching the keyboard or the mouse, I still have no screen response to my keyboard.

I welcome other suggestions.

Rickblee

#4 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:08:45 PM

Posted 23 May 2005 - 01:32 PM

From Windows 2000 Help:
To change the settings for FilterKeys, on the Keyboard tab, under FilterKeys, click Settings.
If the Use shortcut check box in the Settings for FilterKeys dialog box is selected, you can turn FilterKeys on and off by holding down the right SHIFT key for 8 to 16 seconds (depending on the other settings you have selected in the Accessibility Options dialog box). - that sounds like it might have been what you did to turn it on.

If that doesn't work,
Do you have the Logitech disc that came with the keyboard?
Possibly deleting the keyboard through the device manager and reinstalling it might work.
Either that, or just buy an inexpensive keyboard and install it.

Edited by Enthusiast, 23 May 2005 - 01:38 PM.


#5 LoLucky

LoLucky

  • Members
  • 331 posts
  • OFFLINE
  •  
  • Local time:09:45 PM

Posted 23 May 2005 - 01:37 PM

Hey rick try this:
Hold down the Right Shift key for about 10 to 20 seconds. this should pop up the window that you checked those boxes. uncheck those boxes and all should be good.

Also have you rebooted the machine? your keys might be sticky state this is cleared by rebooting the machine.

Edit: HeH Enthusiast beat me by the edit!

Edited by LoLucky, 23 May 2005 - 01:39 PM.


#6 rickblee

rickblee
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:08:45 PM

Posted 23 May 2005 - 03:36 PM

Herk and LoLucky Thanks.

Enthusiast Thanks too. You win the prize. My computer was deaf to my wireless keyboard. Holding down the shift key was useless. But plugging in a wired keyboard allowed me to get into the accessibililty options and turn them off.

Now I need to decide if I have blown 5 hours or taken yet another unexpected course in basic computer management.

Thanks to you my teachers. I'm so happy I did not have to diddle with my registry. That sounds daunting.

Rickblee

#7 Herk

Herk

  • Members
  • 1,609 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:S.E. Idaho, USA
  • Local time:09:45 PM

Posted 23 May 2005 - 06:04 PM

You don't learn anything about computers if they don't break. :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users