Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Registry Problem


  • Please log in to reply
13 replies to this topic

#1 rebellion534

rebellion534

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 12 January 2009 - 10:17 PM

Hello everybody! im not really sure if this is the right section but im using windows xp so im just gonna post it here.

here's the situation guys, let's say Computer A has a virus in it that disabled me from going to safemode ( the F8 method ). everytime i safemood through F8, it just restart back if im gonna press F8 again, it will just go on and on.
then this time, i tried the safemode method using MSconfig through the boot.ini tab (if im not mistaken).
since the virus won't let me go to safemode, Computer A is now stucked. restarting over and over again.

i took the hard drive from Computer A and put it in Computer B, so I can tweak the registry of Computer A through using Computer B.
now, the problem is I can't find the right place where i can remove the Safemode I made by MSConfig. I've been looking for it for hours and can't find it, i also tried googling but can't find one. i hope someone is familiar in my problem.

IN SHORT:
if Safe mode doesn't work, how can u disable Safe Boot through MSconfig.

Edited by rebellion534, 12 January 2009 - 10:33 PM.


BC AdBot (Login to Remove)

 


#2 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:47 PM

Posted 13 January 2009 - 12:55 AM

Open up msconfig.
BOOT.INI tab, uncheck /SAFEBOOT and click OK to restart your computer

#3 lowtek_otc

lowtek_otc

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Local time:02:47 PM

Posted 13 January 2009 - 01:09 AM

Press F8 during boot, and select "Start Windows Normally" or "Normal Mode"

#4 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:47 PM

Posted 13 January 2009 - 01:25 AM

Press F8 during boot, and select "Start Windows Normally" or "Normal Mode"


That won't work. You will still boot into safe mode.
Since safe mode was done in msconfig, it will have to be disabled in msconfg.
If it isn't, you'll be stuck in an endless loop of booting into safe mode.

I just tried this: to see if it would work.
set msconfig to boot to safe mode.
After safe mode loaded, restarted the computer, pressed F8, choose Start Windows Normally, rebooted.
And it still opened in safe mode.
While there, I disabled it in msconfig, restarted and back to normal boot to Windows.

Edited by Queen-Evie, 13 January 2009 - 01:29 AM.


#5 lowtek_otc

lowtek_otc

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Local time:02:47 PM

Posted 13 January 2009 - 01:29 AM

Press F8 during boot, and select "Start Windows Normally" or "Normal Mode"


That won't work. You will still boot into safe mode.
Since safe mode was done in msconfig, it will have to be disabled in msconfg.
If it isn't, you'll be stuck in an endless loop of booting into safe mode.



Of course boot.ini :thumbsup: <- me


I believe you can edit the boot.ini using the recovery console or from another machine.
To remove the safeboot trigger.

Or will the msconfig settings automatically re-write the boot.ini file?

See this is why I never use msconfig to alter settings...

#6 rebellion534

rebellion534
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 13 January 2009 - 01:39 AM

Open up msconfig.
BOOT.INI tab, uncheck /SAFEBOOT and click OK to restart your computer


Press F8 during boot, and select "Start Windows Normally" or "Normal Mode"


That won't work. You will still boot into safe mode.
Since safe mode was done in msconfig, it will have to be disabled in msconfg.
If it isn't, you'll be stuck in an endless loop of booting into safe mode.

I just tried this: to see if it would work.
set msconfig to boot to safe mode.
After safe mode loaded, restarted the computer, pressed F8, choose Start Windows Normally, rebooted.
And it still opened in safe mode.
While there, I disabled it in msconfig, restarted and back to normal boot to Windows.


it won't work since there's a virus that prevents me to safe mode. i can't go for normal mode either because it is configured to safeboot. and now im stuck in the endless loop :thumbsup:

but im trying to google about some MS-DOS Booting stuff, im not really pc expert so it may take some time. :flowers:

i wonder if there is a way to configure msconfig through registry editor.

i really made a big mistake ticking that box (safe boot) in the msconfig. :trumpet:

right now, im reading some article about NTFS4DOS, hope it works.

#7 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:47 PM

Posted 13 January 2009 - 01:39 AM

Using the recovery console is over my head, so I won't attempt to try it.
The easiest way is to do it from msconfig.
If that doesn't work, someone else with more knowlege about recovery console will have to chime in as to whether it can be done, and supply instructions on how to do it.

#8 rebellion534

rebellion534
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 13 January 2009 - 01:42 AM

Of course boot.ini :thumbsup: <- me


I believe you can edit the boot.ini using the recovery console or from another machine.
To remove the safeboot trigger.

Or will the msconfig settings automatically re-write the boot.ini file?

See this is why I never use msconfig to alter settings...


yeah, im using a different machine to edit the registry, but can't find the exact command/value or whatever u call it. :flowers:

#9 lowtek_otc

lowtek_otc

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Local time:02:47 PM

Posted 13 January 2009 - 02:01 AM

Of course boot.ini :thumbsup: <- me


I believe you can edit the boot.ini using the recovery console or from another machine.
To remove the safeboot trigger.

Or will the msconfig settings automatically re-write the boot.ini file?

See this is why I never use msconfig to alter settings...


yeah, im using a different machine to edit the registry, but can't find the exact command/value or whatever u call it. :flowers:


WARNING!
You should have made no changes to your registry. Please to not alter any files or settings on the damaged machine yet.
Since you have the hard drive connected to another computer, scan it for malware thoroughly!
Backup your existing boot.ini file before making any changes to it!


The boot.ini file is located in the root (:\) directory of the hard drive in question. DO NOT confuse the boot.ini file on the drive with your boot.ini file on the C:\ drive of your working computer!
It is a hidden system file so you will need to enable those to be shown.

To see hidden and system files:
On the Tools menu in Windows Explorer, click Folder Options.
Click the View tab.
Under Hidden files and folders, click Show hidden files and folders.
Uncheck the "hide system files" selection as well.
Apply

Open the file in notepad and remove the /SAFEBOOT trigger. Save it (assuming you have a backup!). Put the drive back in the other computer and try to boot.

Edited by lowtek_otc, 13 January 2009 - 02:06 AM.


#10 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:02:47 PM

Posted 13 January 2009 - 02:18 AM

Can you get to the options screen when you press F8? I've been all over those options looking for things you can try. Found 2 of them.

If you can, try Enable Boot Logging. See if you can get msconfig to open up there in order to disable it.

Another one to try: Safemode with Command prompt.
Close out the command prompt.
Press the ctrl-shift-esc keys at the same time. You may have to try this a few times. This will bring up task manager.
In task manager, Applications tab.
At the bottom, choose New Task.
Type in msconfig.

If either of these work to get you msconfig, use the process I described above.

Make sure to apply the changes, then click OK.
Reboot to see what happens.

Edited by Queen-Evie, 13 January 2009 - 02:23 AM.


#11 rebellion534

rebellion534
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 14 January 2009 - 02:39 PM

WARNING!
You should have made no changes to your registry. Please to not alter any files or settings on the damaged machine yet.
Since you have the hard drive connected to another computer, scan it for malware thoroughly!
Backup your existing boot.ini file before making any changes to it!


The boot.ini file is located in the root (:\) directory of the hard drive in question. DO NOT confuse the boot.ini file on the drive with your boot.ini file on the C:\ drive of your working computer!
It is a hidden system file so you will need to enable those to be shown.

To see hidden and system files:
On the Tools menu in Windows Explorer, click Folder Options.
Click the View tab.
Under Hidden files and folders, click Show hidden files and folders.
Uncheck the "hide system files" selection as well.
Apply

Open the file in notepad and remove the /SAFEBOOT trigger. Save it (assuming you have a backup!). Put the drive back in the other computer and try to boot.



Sorry for the very late reply.

i tried searching for malwares and viruses, but im afraid that most of the affected files are some windows file.

i didn't touch anything in the registry yet, the only thing im looking for is the safeboot trigger in regedit, but since i can't find it i need to find another way.

i managed to find the the boot.ini but everytime im trying to open it, it always says "access denied".

right now im trying a program called "Ultimate Boot CD", im gonna try it if i can access boot.ini while booting.

Edited by rebellion534, 14 January 2009 - 02:43 PM.


#12 rebellion534

rebellion534
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 14 January 2009 - 02:44 PM

Can you get to the options screen when you press F8? I've been all over those options looking for things you can try. Found 2 of them.

If you can, try Enable Boot Logging. See if you can get msconfig to open up there in order to disable it.

Another one to try: Safemode with Command prompt.
Close out the command prompt.
Press the ctrl-shift-esc keys at the same time. You may have to try this a few times. This will bring up task manager.
In task manager, Applications tab.
At the bottom, choose New Task.
Type in msconfig.

If either of these work to get you msconfig, use the process I described above.

Make sure to apply the changes, then click OK.
Reboot to see what happens.


i tried both of those options, but the it won't let me, it just restarted back.

#13 lowtek_otc

lowtek_otc

  • Members
  • 280 posts
  • OFFLINE
  •  
  • Local time:02:47 PM

Posted 14 January 2009 - 03:29 PM

i managed to find the the boot.ini but everytime im trying to open it, it always says "access denied".



It is possible to change the permissions of the file however that is not what you want to do since it will need to be used on your main computer.

Just to be certain, make sure you right click the file, choose properties, and uncheck the "Read Only" selection.

#14 rebellion534

rebellion534
  • Topic Starter

  • Members
  • 40 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 14 January 2009 - 04:34 PM

i managed to find the the boot.ini but everytime im trying to open it, it always says "access denied".



It is possible to change the permissions of the file however that is not what you want to do since it will need to be used on your main computer.

Just to be certain, make sure you right click the file, choose properties, and uncheck the "Read Only" selection.


PROBLEM SOLVED!! :thumbsup:
okay, i want to share how i did it, for anyone would encounter this problem.
i downloaded a program called Ultimate Boot CD burned in a CD,
then i run it on the boot process, from there i run a program called EditBINI.
it is a program that let you edit bini file. I just erased the /SAFEBOOT in the line.

Thanks Lowtec and Queen-Evie for the massive time for helping me :inlove: :flowers:

but i still have the problem to get rid of the virus though. :trumpet:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users