Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BattleField 2 Black Screen


  • Please log in to reply
6 replies to this topic

#1 Schwinnstingray1964

Schwinnstingray1964

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Marine City, Mi.
  • Local time:09:42 AM

Posted 04 January 2009 - 12:00 AM

I open up BF2.


And it shows me the logo, then a black screen then back to the desktop.




Kinda sucks, anyone know whats up?
::'00 Thinkpad:::'09 Aspire One:::'07 WL1:::'10 SS2::

If its got two B's its for me. BlackBerry for ever.

"The problem is not that we have too many fools, it's that the lightning isn't distributed right."

--White Lightning 1 & The Silver Surfer 2-- Anybody for TF2???

BC AdBot (Login to Remove)

 


#2 Tehsplink

Tehsplink

  • Members
  • 120 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Near London
  • Local time:03:42 PM

Posted 04 January 2009 - 06:57 AM

Did you install the latest patch?
What are your system specs?
Have you just installed the game, or did it happen one day?
Have you had the game on your computer before, and uninstalled it?

These are 4 important questions that would help everyone to diagnose your problem ;)



Here is what one user from the techguy forums wrote:

Ok, I solved the problem. If anyone else who is having this problem, here is what I did.

Went to:

Document > BAttlefield 2 > Profile
-Open up the Audio.con File
- under *AudioSettings.setProvider "software"* Change "software" to "Hardware"
-IT should look like this with change ------> AudioSettings.setProvider "hardware"

So here is how my audio.con file looks like now.

AudioSettings.setVoipEnabled 1
AudioSettings.setVoipPlaybackVolume 1
AudioSettings.setVoipCaptureVolume 1
AudioSettings.setVoipCaptureThreshold 0.1
AudioSettings.setVoipBoostEnabled 0
AudioSettings.setVoipUsePushToTalk 1
AudioSettings.setProvider "hardware"
AudioSettings.setSoundQuality "High"
AudioSettings.setEffectsVolume 1
AudioSettings.setMusicVolume 0.33
AudioSettings.setHelpVoiceVolume 1
AudioSettings.setEnglishOnlyVoices 0
AudioSettings.setEnableEAX 1

Or you can try this fix from the same user...

go to Document > Battlefield 2 > Profile
-Open up video.con using text document.

Try launching the game at different resulotion. My freinds PC would only launch at 1600x1200 on window vista. Try out different resolution compatible with your monitor in order for it to work.



One page on tweakguides says this (http://www.tweakguides.com/BF2_3.html)...

Launching/Loading Issues: The most common problem with BF2 is that the game crashes to desktop or goes to a black screen when you first launch it. The reason for this is either incompatible hardware (make sure you meet all the minimum specs), or more usually the fact that you're not running at the default Windows XP refresh rate (60Hz). By default the game tries to launch at 800x600@60Hz initially, so your system must be able to run that same resolution and refresh rate, otherwise the game will abort. If you are using any refresh rate override program/method, disable it (e.g. if you're using Refresh Force, click the 'Restore Original Settings' button and apply). Alternatively, see the Advanced Tweaking section of the guide for details on how to set a different startup resolution, in case your graphics card/monitor simply cannot do 800x600@60Hz resolution. Once you've got the game running, you can then change the resolution to suit your taste in the in-game settings, and importantly you can select a higher refresh rate. Then you can reapply any refresh rate override and the game will launch without any problems. To set a non-standard resolution see the Advanced Tweaking section.




Hope those fixes can be of some use, but if not please provide us with the 4 initial questions :thumbsup:



Good luck ;)
Please PM me if i have been assisting you and do not reply for 24 hours!

#3 Schwinnstingray1964

Schwinnstingray1964
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Marine City, Mi.
  • Local time:09:42 AM

Posted 04 January 2009 - 09:38 AM

Did you install the latest patch?
What are your system specs?
Have you just installed the game, or did it happen one day?
Have you had the game on your computer before, and uninstalled it?

These are 4 important questions that would help everyone to diagnose your problem ;)


Yes, im running the latest patch.

My specs are all good (I think...)

I just installed it

Nope.


I think i found my problem... ATi Radeon...

I hate this thing, it shuts down my comp every 4 minutes...


And when i take it out, nothing runs right.


Are there other options in video card than ATi?
::'00 Thinkpad:::'09 Aspire One:::'07 WL1:::'10 SS2::

If its got two B's its for me. BlackBerry for ever.

"The problem is not that we have too many fools, it's that the lightning isn't distributed right."

--White Lightning 1 & The Silver Surfer 2-- Anybody for TF2???

#4 Sterling14

Sterling14

  • Members
  • 1,842 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York
  • Local time:09:42 AM

Posted 04 January 2009 - 11:24 AM

If you're having problems with your graphics card, you should first try updating the drivers. Go here: http://ati.amd.com/support/driver.html, and follow the steps.
"I think there is a world market for maybe five computers." - Thomas Watson, Chairman of IBM, 1943

#5 Tehsplink

Tehsplink

  • Members
  • 120 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Near London
  • Local time:03:42 PM

Posted 04 January 2009 - 11:26 AM

To answer your question, yes.


nVidia cards are excellent.
If your looking for a decent card go for the 9800GTX which is what my gaming PC has and its pretty dope :thumbsup:
If your looking for a pretty cheap graphics card that plays some older games, then i would suggest the 6600GT (Which is in this machine, which is my work machine)
It plays games such as TF2, DOD:S, CS:S. It also plays 2142, and bf2 on low settings. It it also pretty easy to internally overclock it using the control panel.

If you require any more assistance feel free to reply or pm me.
Please PM me if i have been assisting you and do not reply for 24 hours!

#6 Schwinnstingray1964

Schwinnstingray1964
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Marine City, Mi.
  • Local time:09:42 AM

Posted 04 January 2009 - 11:53 AM

You guys know your stuff, eh?


So nvidia is the way to go?
::'00 Thinkpad:::'09 Aspire One:::'07 WL1:::'10 SS2::

If its got two B's its for me. BlackBerry for ever.

"The problem is not that we have too many fools, it's that the lightning isn't distributed right."

--White Lightning 1 & The Silver Surfer 2-- Anybody for TF2???

#7 Tehsplink

Tehsplink

  • Members
  • 120 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Near London
  • Local time:03:42 PM

Posted 04 January 2009 - 12:13 PM

You guys know your stuff, eh?


So nvidia is the way to go?

In my honest opinion, when i try ATI i always get compatibility issues, but with nVidia as long as you keep it up to date then Compatibility issues are kept to a minimum.



Good luck :thumbsup:
Please PM me if i have been assisting you and do not reply for 24 hours!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users