Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox CPU usage


  • Please log in to reply
3 replies to this topic

#1 cpr1955

cpr1955

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 03 January 2009 - 06:59 AM

Hi - I am a new member here. I am not a savvy computer user, so please forgive any errors.

The Firefox browser on my XP seems to use a lot of CPU capacity. I can hear my computer whirring louder and louder. When I open Task Manager and check the "CPU Usage" at the bottom, it typically is running at 40% - 60% (sometimes faster).

Any ideas about what is going on? Thanks!

BC AdBot (Login to Remove)

 


#2 Tehsplink

Tehsplink

  • Members
  • 120 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Near London
  • Local time:12:07 AM

Posted 03 January 2009 - 08:16 AM

The first thing I will suggest to you, is check that it is actually Firefox using all of that CPU.
Go into Task Manager, click on the Processes tab, and look for Firefox.exe, then look across and check that the cpu is from that process.


:thumbsup:
Please PM me if i have been assisting you and do not reply for 24 hours!

#3 cpr1955

cpr1955
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:07 PM

Posted 03 January 2009 - 09:26 AM

I did do that, and it was Firefox using all the CPU.

#4 CarbonX

CarbonX

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:07:07 PM

Posted 03 January 2009 - 02:56 PM

Have you got any Plugins which might be slowing it down?

And can you post your computer specs? Your computer may not fit the requirements.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users