Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't start automatic updates service


  • Please log in to reply
3 replies to this topic

#1 chadoww

chadoww

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Murfreesboro, TN
  • Local time:06:28 PM

Posted 25 December 2008 - 11:47 PM

Hello,

I am trying to update windows on my mother in law's computer (XP) but I am unable to do so. I went into services and BITS and Event Log are started but Automatic Updates are disabled.

I will set it to automatic and then click start to start the service and it displays the following error:

"Could not start automatic updates service on local computer. Error 1058. The service can't be started either because it is disabled or it has no enabled devices associated with it".

If there is any help anyone can provide it would be greatly appreciated.

Thanks.

BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,277 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:28 PM

Posted 26 December 2008 - 12:50 AM

Go to Start> Run and type in CMD.EXE and then click OK.

When the black page with the white lettering opens type in the following and then click on enter.

rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %systemroot%\inf\au.inf

Running this command prompts you for the XP installation CD. Use Browse button and navigate to C:\Winnt\Servicepackfiles\I386 where wuapi.dll and other files related to Automatic Update Client can be found. After running this command, you must restart your computer.

Once restarted, you can open the Services control panel applet and check to ensure the Automatic Update Service is installed.



http://www.wsuswiki.com/Proceduretomanuall...ticUpdateClient

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,089 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:07:28 PM

Posted 26 December 2008 - 07:01 PM

Try setting the Automatic Updates service to Automatic.
Then click OK to apply the changes
Then reopen the dialog and then try to start the service.

Exit the dialog again to see if the Automatic Updates service has returned to Disabled - if so, I'd suspect malware and would recommend a couple of these free, online scans: http://www.bleepingcomputer.com/blogs/usas...?showentry=1252
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 chadoww

chadoww
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Murfreesboro, TN
  • Local time:06:28 PM

Posted 24 January 2009 - 04:45 PM

Sorry it took so long for a response. The issue has been corrected. The computer was completely whacked and I had to wipe it out and start from scratch.

Thanks for the help anyways.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users