Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Java Broken on WinXP


  • Please log in to reply
3 replies to this topic

#1 tide

tide

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:14 PM

Posted 11 December 2008 - 06:28 AM

My Java applications (e.g. Maple, MATLAB etc.) no longer run on my system. It all began about two weeks ago after I downloaded and installed the Java Development Kit (JDK). (I thought I might like to learn something about Java programming). The next day, I had lost the use of my keyboard. Whether JDK was responsible that, I can't say for sure, but I managed to fix that problem and promptly uninstalled JDK.

Shortly thereafter, I discovered one by one that programs relying on Java would not run. First, Maple, then MATLAB and on to SciLAB and so on. Where a program will at least show an error message they all begin with something like java.lang.NoClassDefFoundError.

I thought that reinstalling Java might fix the problem so I downloaded and installed JRE6 but that didn't help. I tried setting environment variables (CLASSPATH, JAVA_HOME). Again, no luck. I tried uninstalling all the old versions of JRE also to no avail. I tried many permutations of reinstalling old and new versions of JRE. I discovered that at least one (other) program would run if I had JRE1.5 installed with no JRE6 but it would fail again if I reinstalled JRE6. My main programs (listed above) will not run with any combination of JRE's.

This has gotten awfully frustrating and I'm out of ideas. I'd like to have the use of those programs again (sooner rather than later!) and would appreciate any help you could provide. Thanks!

BC AdBot (Login to Remove)

 


#2 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:14 PM

Posted 13 December 2008 - 07:23 AM

Hello tide and welcome to BC.

I would first try using http://raproducts.org/ JavaRa, this tool should help you remove all out of date java components and update to the latest components.

Let us know if you run in to problems.
Regards,

Alan.

#3 tide

tide
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:14 PM

Posted 14 December 2008 - 06:10 AM

Thank you, Alan!

I tried JavaRa followed by a reboot followed by a registry cleaner followed by a reboot followed by installation of JRE6 followed by a reboot - whew! Unfortunately, it didn't work. :thumbsup:

I can't even open the Java control panel. I click on the icon in the Windows control panel and nothing happens.

#4 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:14 PM

Posted 14 December 2008 - 02:17 PM

The event viewer may give some more information.

1. Click Start select run
2. Type eventvwr.exe
3. Press enter
4. Search through the groups for errors and warnings.
5. Double click on each error and or warning.
6. Locate the copy to clipboard button, Posted Image (under the two arrows)
7. Let us know what you find. (paste the results)
Regards,

Alan.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users