Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Linux/WinXP Boot Problem "Black Screen"


  • Please log in to reply
1 reply to this topic

#1 morth

morth

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:06:50 AM

Posted 09 December 2008 - 06:05 AM

I'm currently having a Boot problem with Windows XP.
The other night i was watching youtube videos and a random Command Prompt popped up and my computer started making noises i got got scared and rebooted.
When i tried to reboot it would go to a black screen and not boot.
only allows me to get on linux.

Whats wrong?

I'm Currently Dualboot - Linux "Ubuntu & Windows XP"
when i get to the boot window i select windows and it says starting up.. for a couple ms and then BAAM! it goes to a black blank screen, only way out is to reboot.
first thing that came to my head was boot cd - chkdsk well..
booting from a cd doesnt go well either, Press any key to Continue... (Anykey*) then Checking PC Hardware or something.. few moments later BAAM! it goes to a black blank screen, only way out is to reboot.

Floppy Disk - Chkdsk doesnt work so i tried Scandisk - got this issue "You Cannot Check or Repair drive C because it was created by using INTERLINK.

Btw the Linux and Windows is on the Same hard drive.

Okay so Windows wont boot? not a problem!... WRONG
Boot into Linux Perfectly fine, might as well just make Backup of the Windows and Reformat.
well the WindowsXP Drive is there but said it couldn't mount.. Details said "Unclean Shutdown"
some hours later and a few smacks to the case WindowsXP Opens but blank folder.. it says the right space is being used and free but its empty..

i tried a few things out people trying to help me on IRC - #ubuntu & #Windows, Bleepingcomputer.

Nothing seems to work.
Btw im new to Linux so if you're going to post me commands im gunna need you to hold my hand :thumbsup: thanks.

Btw heres some more information just incase if it helps.

"sudo fdisk -l"

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcff2cff2

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4864 39070048+ 7 HPFS/NTFS
/dev/sda2 4865 9729 39078112+ 5 Extended
/dev/sda5 4865 9524 37431418+ 83 Linux
/dev/sda6 9525 9729 1646631 82 Linux swap / Solaris



Thank you.
Morth

PS: If it cannot be fixed is there away to make backup to the files? - i have important files on my WinXP and i really dont want to lose them.
i think im going to invest in a External Hard drive and make backup ever so often.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:07:50 AM

Posted 09 December 2008 - 11:28 AM

You can try the fixmbr and fixboot commands in the recovery console
http://support.microsoft.com/kb/314058
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users