Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

First hard drive not detected


  • Please log in to reply
1 reply to this topic

#1 kjm782

kjm782

  • Members
  • 30 posts
  • OFFLINE
  •  
  • Local time:11:49 AM

Posted 07 December 2008 - 01:30 PM

I recently purchased 2 Seagate ES.2 750gb drives. The problem I am having is that the first hard drive is not detected initially. If I restart the computer (either with a hard reset or by going into the BIOS and then exiting so that it goes through the POST process again) it is detected fine.

I have tried changing the power cables and sata cables. I have also reversed the order that the drives are plugged in. It doesn't matter what I do, the hard drive that is plugged into the lowest SATA slot is not detected. If I go into the BIOS and do an autodetect of the hard drives the first drive shows up as only 136gb. I have also tried plugging a third hard drive (also a Seagate, but an older model) into a SATA slot ahead of my ES.2 drives and the old drive is detected but the first of the new drives is not.

I have tried flashing the BIOS to the newest version but that hasn't fixed it. I am assuming this is a motherboard issue because it doesn't matter which drive, it only seems to be affected by the order in which they are plugged in. I looked at the SMART data on the drives and I don't see any problems. Needless to say, unless I remember to restart the computer every time I turn it on this is wrecking havoc with a RAID setup that I wanted to use. Does anyone have any suggestions for how to fix this?

My motherboard is a Gigabyte GA-M57SLI-S4 (rev. 2.0)
http://www.giga-byte.com/Products/Motherbo...?ProductID=2539

Edited by kjm782, 07 December 2008 - 01:34 PM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,874 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:11:49 AM

Posted 07 December 2008 - 03:07 PM

Just guessing...

If you have a RAID 1 setup...one of your drives will "disappear", since the combined drives are only seen as having the volume of one drive (of the same size).

http://www.pcguide.com/ref/hdd/perf/raid/l...leLevel1-c.html

But...that doesn't account for what happens on reboot.

Maybe that BIOS flash was uncalled for, but...the BIOS settings are where I would look.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users