Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

desktop background images disabled


  • Please log in to reply
3 replies to this topic

#1 redgar

redgar

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:55 PM

Posted 04 December 2008 - 11:01 AM

There is something preventing my desktop background pictures from appearing. I can select the solid background colors, but upon selecting images, they do not appear. In stretched mode, there is a missing image icon in the top left corner of the screen. I can see the desktop at startup and shutdown when whatever is covering my desktop is inactive.

This is the third time I have seen this happen as a result of a certain spyware (prunnet, wlloginproxy.exe). It is a rootkit. Well I removed everything except I still cant see my desktop background.

I have tried using vb scripts to clean my desktop. I used a couple popular ones but they only removed the problem for a second, and then it was reinitialized. I have deleted or deactivated all the nodesktop entries in the registry and tried deleting and removing all of the activedesktop entries. I actually got the problem deactivated (but not fixed) by turning off activedesktop via the registry. I was not totally satisfied though, and I reran all the vbs desktop cleaners and the problem returned.

Can ANYONE help me? I have read probably 50 forum entries across the net for 3 days and there are so many similar problems that it has been impossible to find the solution to this more recent method of deactivating the desktop.

BC AdBot (Login to Remove)

 


#2 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,573 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:55 AM

Posted 04 December 2008 - 04:24 PM

Right click on the desktop and select Properties > Desktop tab > Customize Desktop button > Web tab. If there is an entry there delete it and then click OK. Now you should be able to change the desktop background.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#3 redgar

redgar
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:55 PM

Posted 05 December 2008 - 01:50 AM

This didn't fix the problem. There was nothing selected and nothing to delete.

The problem was related to active desktop, but was not fixable through this. I will say that my solution is rather generic, and I don't believe a true fix. However, it does allow my desktop background to be displayed.

I edited the registry entries for disable active desktop (noactivedesktop key), and changed them to true (1). This can be done through microsoft management console as well (mmc).

I say its not a true edit because I would think that enabling active desktop wouldn't result in your desktop background being covered. I don't know though because I haven't used it much.

Edited by redgar, 05 December 2008 - 02:00 AM.


#4 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:05:55 PM

Posted 05 December 2008 - 05:34 PM

Not sure if this is the cause, but for what it is worth if your copy of Windows did not pass validation with Microsoft then you will lose the ability to have a background. You might be able to set it up and get it working for a while, but then it will go to black again.

Again, not sure if this is the cause.

Along with losing your background you should see a rather large notice in the lower right corner of your screen, down near the clock, that says you did not pass validation.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users