Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

load needed dlls for hal


  • Please log in to reply
No replies to this topic

#1 gclipse02

gclipse02

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:42 AM

Posted 29 November 2008 - 01:47 PM

I am trying to fix a Windows Server 2003 Standard Edition which has recently stopped working. The problems began when the server somehow installed updates when it is setup not to install ANY updates. When I accessed it yesterday morning, the screen said to reboot to finish the installed updates. The reason I even bothered looking at it was because the network was down. It is a Domain Controller DHCP host, with Active Directory, and is setup for file sharing. At the time, none of the computers on the network could access the shared drive, reading a message like "can't access drive; local name already in use," or something to that effect. My thoughts were to reboot the Server to finish the updates. No dice. It rebooted fine, but no change to the network situation. So I tried a restore using Directory Services Restore mode, but only to the System State backed up on 10/02/08, (server install on 09/24/08) not including the files and folders, and not overwriting anything. Everything seemed to go fine until I tried rebooting. That's when the Load Needed DLLs for Hal came up. My current knowledge told me that there were some drivers missing off the hardware access layer list, and research confirms that.

Here's the catch. I've gone through and replaced the Hal.dll and ntoskrnl.exe files, and I'm to the point where it's saying the ntoskrnl.exe is corrupt or missing. I've even tried renaming the ntosmp.exe (I think that was the name) to ntoskrnl.exe as per the setup.log file, but it's a no-go still.

A little physical info on the machine which is affecting my work I believe: There is an Nvidia Raid controller connected to two SATA drives in RAID 0. Seeing as how I have to load special drivers when booting to Repair mode, I have a feeling that they need to be included on my Hal.dll, but I'm not sure...

I'd really appreciate any help I can get on this matter. Thanks

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users