Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wierd Connection Problems


  • This topic is locked This topic is locked
5 replies to this topic

#1 ^MavericK!

^MavericK!

  • Members
  • 125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Monterrey
  • Local time:11:58 PM

Posted 28 November 2008 - 05:24 PM

Hi it's been a while since I posted here and Again I'm looking for help...

This started a while ago, like 2 weeks, I was looking for an owner's manual for my home theater, when I got the typical “you have been infected by spyware” window, but when this window opened FireFox closed. I opened the task manager and killed the process instead of clicking yes or not. I use Sygate firewall and every since then there is a connection blocked from the net to my PC.
Attached File  untitled.JPG   926bytes   0 downloads
Every since then I have had very low speeds And every time I try to install something or just go to the net I get a popup of my PC trying to connect to wpad.mmredes.net (mmredes is my ISP, but I really don’t recognize the wpad thing. I blocked this in my firewall) it goes to an IP in the USA according to WhoIs. When I go to a server to online play I get very high pings while my firewall is blocking it, but when I set the firewall to “Allow All” My ping go down for a while then it just goes up and down. I have tried scanning with System Mechanics, Malawarebytes, Spyware Search&Destroy, etc…

System Mechanics found 2 parasites and deleted them, MalawareBytes found one and deleted it, Spybot states I have no spyware.

I’m thinking in reformatting my whole system, but I wanted to come here and see if someone can help me before I do that.

Here is my HijackThis! Log

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 15:38:31, on 11/28/2008
Platform: Windows XP SP3 (WinNT 5.01.2600)
MSIE: Internet Explorer v7.00 (7.00.6000.16735)
Boot mode: Normal

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\csrss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Sygate\SPF\smc.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\svchost.exe
C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
C:\Program Files\Alwil Software\Avast4\ashServ.exe
C:\WINDOWS\Explorer.EXE
C:\WINDOWS\system32\spoolsv.exe
C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
C:\Program Files\Java\jre6\bin\jusched.exe
C:\Program Files\Analog Devices\Core\smax4pnp.exe
C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe
C:\Program Files\Razer\Diamondback\razerhid.exe
C:\Program Files\Atomic Alarm Clock\AtomicAlarmClock.exe
C:\WINDOWS\system32\ctfmon.exe
C:\Program Files\SpeedFan\speedfan.exe
D:\Program Files\East-Tec Eraser 2008\etRiskMon.exe
C:\Program Files\a-squared Free\a2service.exe
C:\Program Files\iolo\common\lib\ioloServiceManager.exe
C:\Program Files\Java\jre6\bin\jqs.exe
D:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
C:\Program Files\NVIDIA Corporation\NetworkAccessManager\bin\nSvcIp.exe
D:\Program Files\NVIDIA Corporation\nTune\nTuneService.exe
C:\WINDOWS\system32\nvsvc32.exe
C:\WINDOWS\system32\PnkBstrA.exe
C:\Program Files\NVIDIA Corporation\NetworkAccessManager\bin\nSvcAppFlt.exe
C:\WINDOWS\System32\wbem\wmiprvse.exe
C:\Program Files\Razer\Diamondback\razertra.exe
C:\Program Files\Razer\Diamondback\razerofa.exe
C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe
C:\Program Files\Alwil Software\Avast4\ashWebSv.exe
C:\WINDOWS\System32\alg.exe
D:\Program Files\Anti Trojan Elite\TJEnder.exe
C:\Program Files\Windows Live\Messenger\msnmsgr.exe
C:\Program Files\Windows Live\Messenger\usnsvc.exe
D:\Program Files\Winamp\winamp.exe
D:\Program Files\Spybot - Search & Destroy\SpybotSD.exe
C:\Program Files\a-squared Free\a2free.exe
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Documents and Settings\^MavericK!\Desktop\HiJackThis.exe
C:\WINDOWS\System32\wbem\wmiprvse.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,First Home Page = http://go.microsoft.com/fwlink/?LinkId=54843
O2 - BHO: Adobe PDF Link Helper - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\Program Files\Microsoft Office\Office12\GrooveShellExtensions.dll
O2 - BHO: Java™ Plug-In SSV Helper - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre6\bin\ssv.dll
O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)
O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: Java™ Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll
O2 - BHO: JQSIEStartDetectorImpl Class - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} - C:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll
O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
O4 - HKLM\..\Run: [WinampAgent] "D:\Program Files\Winamp\winampa.exe"
O4 - HKLM\..\Run: [TrojanScanner] D:\Program Files\Trojan Remover\Trjscan.exe /boot
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files\Java\jre6\bin\jusched.exe"
O4 - HKLM\..\Run: [SoundMAXPnP] C:\Program Files\Analog Devices\Core\smax4pnp.exe
O4 - HKLM\..\Run: [SmcService] C:\PROGRA~1\Sygate\SPF\smc.exe -startgui
O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [GrooveMonitor] "C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe"
O4 - HKLM\..\Run: [Diamondback] C:\Program Files\Razer\Diamondback\razerhid.exe
O4 - HKLM\..\Run: [Malwarebytes' Anti-Malware] "D:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe" /starttray
O4 - HKCU\..\Run: [SkinClock] C:\Program Files\Atomic Alarm Clock\AtomicAlarmClock.exe
O4 - HKCU\..\Run: [NVIDIA nTune] "D:\Program Files\NVIDIA Corporation\nTune\nTuneCmd.exe" clear
O4 - HKCU\..\Run: [Eraser RiskMonitor] "D:\Program Files\East-Tec Eraser 2008\Launch.exe" "D:\Program Files\East-Tec Eraser 2008\etRiskMon.exe"
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
O4 - Startup: SpeedFan.lnk = C:\Program Files\SpeedFan\speedfan.exe
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000
O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\Office12\REFIEBAR.DLL
O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\WINDOWS\System32\shdocvw.dll
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\WINDOWS\System32\shdocvw.dll
O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) - http://update.microsoft.com/microsoftupdat...b?1222478111718
O18 - Protocol: grooveLocalGWS - {88FED34C-F0CA-4636-A375-3CB6248B04CD} - C:\Program Files\Microsoft Office\Office12\GrooveSystemServices.dll
O23 - Service: a-squared Free Service (a2free) - Emsi Software GmbH - C:\Program Files\a-squared Free\a2service.exe
O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashServ.exe
O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe
O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashWebSv.exe
O23 - Service: ForceWare Intelligent Application Manager (IAM) - Unknown owner - C:\Program Files\NVIDIA Corporation\NetworkAccessManager\bin\nSvcAppFlt.exe
O23 - Service: iolo FileInfoList Service (ioloFileInfoList) - Unknown owner - C:\Program Files\iolo\common\lib\ioloServiceManager.exe
O23 - Service: iolo System Service (ioloSystemService) - Unknown owner - C:\Program Files\iolo\common\lib\ioloServiceManager.exe
O23 - Service: Java Quick Starter (JavaQuickStarterService) - Sun Microsystems, Inc. - C:\Program Files\Java\jre6\bin\jqs.exe
O23 - Service: MBAMService - Malwarebytes Corporation - D:\Program Files\Malwarebytes' Anti-Malware\mbamservice.exe
O23 - Service: ForceWare IP service (nSvcIp) - NVIDIA Corporation - C:\Program Files\NVIDIA Corporation\NetworkAccessManager\bin\nSvcIp.exe
O23 - Service: nTune Service (nTuneService) - NVIDIA - D:\Program Files\NVIDIA Corporation\nTune\nTuneService.exe
O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe
O23 - Service: PnkBstrA - Unknown owner - C:\WINDOWS\system32\PnkBstrA.exe
O23 - Service: Sygate Personal Firewall (SmcService) - Sygate Technologies, Inc. - C:\Program Files\Sygate\SPF\smc.exe
O23 - Service: StarWind AE Service (StarWindServiceAE) - Unknown owner - D:\Program Files\Alcohol Soft\Alcohol 120\StarWind\StarWindServiceAE.exe (file missing)

--
End of file - 8019 bytes

I’m currently performing a scan with Anti Troyan Elite, but it has been 15 hours and it has not gone trough half my HD’s and it has not found anything.

Any help will be very appreciated…

Mav

Edited by ^MavericK!, 28 November 2008 - 05:27 PM.


BC AdBot (Login to Remove)

 


#2 ^MavericK!

^MavericK!
  • Topic Starter

  • Members
  • 125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Monterrey
  • Local time:11:58 PM

Posted 28 November 2008 - 10:10 PM

Let me add the fact I have 6 svchost running

Attached File  svchost.JPG   49.7KB   9 downloads

Anyone?


Mav

#3 ^MavericK!

^MavericK!
  • Topic Starter

  • Members
  • 125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Monterrey
  • Local time:11:58 PM

Posted 03 December 2008 - 05:01 AM

I'm really sorry for "bumping" my topic but I already reformated my PC lots of times and still have the same issue. Could this be to my modem?

Attached File  hack.JPG   96.22KB   20 downloads

This is after a fresh install, I just installed My AV and my Firewall, not even my graphic driver is instaled

Again I'm sorry, but I really don't know what to do with this. I called my ISP and asked them to reset my modem on their side and still the same issue.

Please help...

#4 ^MavericK!

^MavericK!
  • Topic Starter

  • Members
  • 125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Monterrey
  • Local time:11:58 PM

Posted 09 December 2008 - 11:46 AM

Well I guess no one has a clue on this. This is the whole story...

I noticed the fact of my PC wanting to connect to that address like 4 - 5 weeks ago, at first I thought it was valid so most of the time I will click on yes. But I noticed that when I launched an installer or an update was done in my PC, even a internal search will trigger that and I thought, why will my ISP want to know that. So I eventually started to deny the connection.

One day while looking for a user manual of a Home theater I recently got and suddenly FireFox closed and a "you have spyware" window opened. After this it started to affect me in game servers, My ping went from 35 to 250, so impossible to play, sometimes It will give me a break and give me good pings, but in a while I will go back to 250+. When trying to download something from the net it will time out or download it in very slow speeds. I also noticed It changed names, it will go to spdf.mmredes.net, goli.mmredes.net, etc...

I changed HD, got a new NIC and installed it reformatted my HD's big time, so I'm almost positive it is not on my side.

I almost only play in that PC, so I started to try to investigate, go to forums and post and see if I could get some help. In the meantime I tried every single AntiSpam/Malaware/name it to see if I could get the infection. No answer.

This topic here sitting since Nov 28 with no answer but lots of views.

So I decided to reformat. I have 3 HD's and I can backup everything before doing this. I did it, and the moment I connect to the net it will go to wpad.mmredes.net. This happens when I get an update, a download, even when I search internally my PC. It is weird because it will try to go to that adress, I would deny it, and after a while the same undate will go to the actual adress.

It is incredible I perform a fresh install of Windows, install Avast (which I already changed for Nod 32) Sygate (firewall) and then I will install my Chipset driver and connected the LAN cable and the first thing will be something connecting to wpad.mmredes.net (mmredes.net will be my ISP, but a prefix will change the domain big time).

OK so I installed Linux (Ubuntu) to literally destroy boot sectors for windows and got the same result. I took the battery of the MoBo and left it sitting for more than 10 hours and got the same result. I started to feel like a crazy person cause the definition of crazy is doing the same thing expecting a different result. I have reformatted my PC maybe 20 times in the last 2 weeks.

I taked to a good friend of mine that has lots of knowledge in this and he stated it is a valid ISP in Washington, But why will a valid connection mask itself, why will it change names to get me to click on yes. That's why insist this is a virus infection, or maybe someone is using me as a Proxy or even worse someone is using my PC as a Zombie. Let me add I restart my Modem daily, cause when I'm not home I cut electricity off.

Well I changed to Nod32 as for This friend suggestion, this AV has a feature that will not permit hazardous or potentially bad applications to run. After I installed it and booted up, it stooped an instance of svhost stating it was potentially harmful. Every since then I haven't seen wpad.mmredes.net, I can't open a web page eather it will time out, I changed a setting in Nod32 and I can surf now.

I think I have my Modem hacked by my MAC address, I just don't understand why or by who, and really hope this person will get tired and bother someone else.

I really don't know exactly what happened and if it is fixed, but yesterday I went to a game server and the pings seemed OK, Also I've noticed speeds are back to normal downloading stuff.

I wish I had a reply in this topic of someone that will understand a little what happened to me, mainly to prevent it to happen again.

I was told by this good friend Avast will detect valid software as viruses and viruses as valid scripts, not really sure, but to be on the safe side I changed it. Also I uninstalled Sygate cause I got Nod 32 with Firewall and having 2 firewalls will just make my Pc run slower.


If any Mod feels this topic needs to be moved so I can get some replies, please move it....

Thanks.

#5 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:09:58 PM

Posted 14 December 2008 - 01:03 PM

Hello and :thumbsup: to Bleeping Computer

We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help.

If you have since resolved the original problem you were having, we would appreciate you letting us know. If not please perform the following steps below so we can have a look at the current condition of your machine. If you have not done so, include a description of your problem, along with any steps you may have performed so far.

Upon completing the steps below a staff member will review and take the steps necessary with you to get your machine back in working order clean and free of malware.


Thanks and again sorry for the delay.

We need to see some information about what is happening in your machine. Please perform the following scan:
  • Download DDS by sUBs from one of the following links. Save it to your desktop.
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explaination about the tool. No input is needed, the scan is running.
  • Notepad will open with the results, click no to the Optional_Scan
  • Follow the instructions that pop up for posting the results.
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet. Information on A/V control HERE
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image

#6 Billy O'Neal

Billy O'Neal

    Visual C++ STL Maintainer


  • Malware Response Team
  • 12,304 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Redmond, Washington
  • Local time:09:58 PM

Posted 21 December 2008 - 01:07 AM

Due to lack of feedback, this topic has been closed.

If you need this topic reopened, please send me or another moderator a PM.

Everyone else please begin a new topic.
Twitter - My statements do not establish the official position of Microsoft Corporation, and are my own personal opinion. (But you already knew that, right?)
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users