Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

'Failed to uninstall the device' when deleting drivers.


  • Please log in to reply
1 reply to this topic

#1 swiftbmx

swiftbmx

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:46 AM

Posted 08 May 2005 - 11:07 PM

Hi guys,
I hope some of you can help me out. I upgraded my mini-pci wireless card in my laptop and I'm having trouble getting it to work. It is compatible so thats not the issue. The card I had was an Intel Prowireless 2200BG card and now is an Atheros AR5001x card.

When I install the drivers for the Atheros card, about 75% through the installation, the computer freezes. I have to restart and when I do, during the windows starting progress screen, it freezes. I go into safe mode to delete the Atheros driver from the device manager and when I restart it works. So obviously, there is some sort of conflict. I'm pretty sure the conflict is with the previous Intel 2200BG driver after doing some research.

When in safe mode, the driver/network adapter for the Intel card still shows up. I've tried to disable it, that didn't work. I tried to delete it, I get the 'Failed to uninstall the device. The device may be required to boot up the computer' message in device manager. I've also tried to uninstall Intel ProSet, manually disable the 2200BG in device manager, reboot, uninstall the 2200BG driver but I still get the same message. I need to get rid of this Intel Proset driver, all of its software, and anything associated with it.

If there is a workaround for the 'Failed to uninstall' message, I'd appreciate it if someone could tell me. If someone knows how to get rid of all the drivers for this properly, that would help greatly as well. If I have to do it through regedit, I do not mind as long as someone can explain it thoroughly as I'm no computer expert.

Thanks in advance,
KB

BC AdBot (Login to Remove)

 


#2 rigel

rigel

    FD-BC


  • BC Advisor
  • 12,944 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina - USA
  • Local time:07:46 AM

Posted 09 May 2005 - 07:37 AM

Hi swiftbmx,

Try going into the CMOS setup for your laptop. You may have to press delete or F10 or something similarduring startup. (A message about setup will show during the boot, but before Windows starts) I am guessing the intel adapter is built into your laptop. You may have to disable it in CMOS setup.

After doing that, try reinstalling and the uninstalling the driver for that adapter. Another option would be to reinstall the intel adapter and then disable it.

As for the Atheros AR5001x card, try installing that with your firewall and virus protection turned off. I have seen those block installations. Just be sure to turn both back on when finished.

Good Luck,

Rigel

"In a world where you can be anything, be yourself." ~ unknown

"Fall in love with someone who deserves your heart. Not someone who plays with it. Will Smith





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users