Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Two strange desktop icons/files appeared!


  • Please log in to reply
6 replies to this topic

#1 Uno-Hoo!

Uno-Hoo!

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:13 PM

Posted 19 November 2008 - 12:08 PM

I've just noticed two new desktop icons have suddenly appeared on my laptop. Both are named 'desktop' and when double-clicked they open Notepad and contain the following:

one contains:

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799

The other contains:

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
[LocalizedFileNames]
Windows Mail.lnk=@%ProgramFiles%\Windows Mail\WinMail.exe,-225
Internet Explorer.lnk=@%windir%\System32\ie4uinit.exe,-731

I have no idea where these files have come from, or why. The only alteration I have done to my pc today is to uninstall Zone Alarm (because it was causing me connection problems).

If I attempt to delete this two desktop files I get the following warning:

"Are you sure you want to move this system file to the Recycle Bin?
If you remove this file, Windows or another program might no longer work
correctly."

Anyone any idea what these files are and why they have suddenly appeared on my desktop?

Kev

BC AdBot (Login to Remove)

 


#2 xXAlphaXx

xXAlphaXx

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:13 PM

Posted 19 November 2008 - 01:23 PM

As I recall some one else posted here and had the same problem, I believed we solved it but turning "See Hidden Icons" off.


Give it a shot, see what happens.
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#3 Uno-Hoo!

Uno-Hoo!
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:13 PM

Posted 20 November 2008 - 08:47 AM

That did the trick! Thanks for your help!

Kev

#4 xXAlphaXx

xXAlphaXx

  • Members
  • 867 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carlona
  • Local time:03:13 PM

Posted 20 November 2008 - 01:47 PM

No problem =P

Glad I helped.
If I am helping you and I do not respond within 24 hours, please send me a PM. :)

#5 psycoentric

psycoentric

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:13 PM

Posted 09 March 2009 - 10:56 PM

Was wondering how to do this? I have Vista and right clicked and view but no option to turn these off. Thanks for the read.

#6 Cuessane

Cuessane

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Silverdale, WA
  • Local time:12:13 PM

Posted 09 March 2009 - 11:31 PM

Was wondering how to do this? I have Vista and right clicked and view but no option to turn these off. Thanks for the read.


Open a folder (any folder will do), click Tools, then go to Folder Options. Go to the View tab, and go down to the Hidden Files and Folders options, and check the box labeled 'Hide protected operating system files (Recommended)'.

#7 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:03:13 PM

Posted 10 March 2009 - 08:52 AM

Desktop.ini is a hidden file that represents your Desktop. The other Desktop.ini is a hidden file that represents the All Users/Public Desktop.

When your account is first setup it combines the All Users/Public profile with the Default profile to create your profile. This way you've got access to the All Users/Public stuff from your Desktop.

Desktop.ini shows because something has enabled the viewiing of hidden files. To turn it off, follow the advice given by Cuessane above.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users