Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Newer Western Digital HD Failed. Any Hope of Recovery?


  • Please log in to reply
1 reply to this topic

#1 eDrummer

eDrummer

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:11:15 AM

Posted 18 November 2008 - 09:39 PM

I recently added a Western Digital 320GB IDE HD as a secondary drive to my system (left the boot drive in place). Then I transferred all my pics and music to the new drive. Everything worked fine for about 2-3 months but now Windows nor my BIOS is detecting the drive. I tried putting the drive in an HD enclosure and plugging into another computer...no joy.

I can hear the drive spin up, make the reading/ticking noises and then immediately spin back down. This repeats a few times until it spins all the way down and stops. The ticking doesn't sound particularly nasty but I don't know if that's part of the problem.

I think I can RMA the drive but would like to see if I can recover any of the files first. Any suggestions?

System:
Windows XP SP2
P4 2.2GB
2GB RAM

BC AdBot (Login to Remove)

 


#2 Ellypho

Ellypho

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ottawa, ON
  • Local time:02:15 PM

Posted 18 November 2008 - 09:59 PM

I think the drive may not be recoverable unless it has something to do with the bios. Maybe try resetting the Bios defaults and reinstalling the drive. If that dosent work it may very well be a hardware issue. Also make sure the molex connector(pwr connector for the drive) is well inserted. Sorry man but wait for the imput of other users :thumbsup:

Here try this diagnostic tool too I dont know if it will give any results but it may be worth a try http://support.wdc.com/product/download.as...1=5&lang=en

Edited by Ellypho, 18 November 2008 - 10:03 PM.

CompTIA A+ certified




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users