Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help with Virus or Malware


  • Please log in to reply
4 replies to this topic

#1 CBR954RR

CBR954RR

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 16 November 2008 - 10:06 PM

Well, I have scoured through these forums trying to find an answer to my problems but have yet to get my laptop back to normal. Some how, I have managed to get infected with something that has taken control of my browser and is stopping me from running any application that helps to rid viruses and malware.

I have managed to remove from the registry anything that was loading a file called brastk.exe as well as pointers to av.dat, delself.bat, karna.dat and replaced the infected beep.sys with a fresh copy. Now, these files no longer appear on reboot, nor do they appear in the registry anymore, but my browser still will not let me navigate to sites that will help to remove infections or even the windows update site. If I google something and then click on the link, either another browser window opens with new search results or a window opens with nothing in the window.

Also, I can not install or run applications like Anti-Malware, SuperAntiSpyware, Combofix, HijackThis, etc. They appear to start but then nothing happens.

The machine does boot up, be it Safe Mode, Safe Mode with Networking, or a Normal Boot and the symptoms are exhibited in all boot modes.

Can some one help me sort this out or do I need to do a complete reinstall to fix this? Any and all help greatly appreciated.

Thanks in advance.

- Dan

P.S. OS is Windows XP Pro with SP3
P.S.S I have tried following the Updated 8-step Viruses/Spyware/Malware Preliminary Removal Instructions but as stated above, I can't get the applications to install or run.

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,865 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:01 PM

Posted 16 November 2008 - 10:34 PM

Clean install.

Trying to sort out system malfunctions after an infection...is akin to trying to perform self-surgery by looking in shattered mirror, IMO.

Louis

#3 ~PrEmIuM~

~PrEmIuM~

  • Members
  • 192 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Latvia!!
  • Local time:12:01 AM

Posted 17 November 2008 - 07:47 AM

Your malware was killing AV processes..I know great AV and on-demand scanner with Self-guarding(Kaspersky&Symantec) http://pack.google.com <-Install Norton Security Scan & Spyware Doctor.. Then for Kaspersky- http://soft.softoogle.com/ap/kaspersky-avp...load-7275.shtml and update it with http://letitbit.net/download/944bda98386/N...w3-07.exe.html( just locate AVZ folder ( in desktop)

#4 garmanma

garmanma

    Computer Masochist


  • Members
  • 27,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cleveland, Ohio
  • Local time:06:01 PM

Posted 17 November 2008 - 11:31 AM

Moving to Am I Infected
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#5 CBR954RR

CBR954RR
  • Topic Starter

  • Members
  • 51 posts
  • OFFLINE
  •  
  • Local time:05:01 PM

Posted 19 November 2008 - 11:26 PM

Just wanted to let everyone know that I was able to get my machine back under control. I was able to run SDFix.exe by renaming it to SDFix.bat. This allowed it to extract its files and then I was able to run the bat file within the SDFix folder. I ran this a few times until it came up clean and then was able to run ComboFix. Ran that a couple of times until it came up clean and now all seems back to normal.

Thanks to all that offered suggestions.

- Dan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users