Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


USB external hard drive and jump drive are inaccessible

  • Please log in to reply
1 reply to this topic

#1 warwickma


  • Members
  • 1 posts
  • Local time:10:23 PM

Posted 31 October 2008 - 06:06 PM

Hello all,

About 3 weeks ago I ran into a problem accessing my DVD RW drive, San Disk Cruzer Micro drive, and Western Digital My Book Hard drive. Prior to this time, their use was perfectly normal. Both the jump drive and external hard drive have seen less than 2 months use since purchased.

I am running Vista Ultimate as my OS on an Acer Aspire 5610-4648.

For example, I receive the following message when I plug in my jump drive:

G:\ drive is not accessible
Access is denied

Upon exploring my computer folder, I receive similar notifications for the other drives. The generally show up in the folder with a red slash through them. When I examine the hardware, in Windows Device Manager, it says the DVD RW and USB devices are working properly.

After prior advice based on google searches, I disabled Vista's User Account security setup. I now am able to view DVDs, despite the everpresent red slash, but have not tried to burned a CD or DVD yet.

Meanwhile, my USB hard and jump drives now appear, without a slash, when I attach them to my USB ports. Nonetheless, I still receive the above notification and cannot access either drive. It is clearly not a problem with USB power -- given I can plug in other non-drive devices that require power.

I have a sneaking suspicion that use of these drives is being locked out by Windows security framework. I have been utilizing the administrator account as my primary account since the start. Unfortunately, I have no idea how to start to go about verifying whether inherent characteristics of the Vista security framework suddenly decided to work against me.

This is putting a major crimp in my weekly file back up schedule.

Anybody know what might be causing this highly frustrating condition and how I might go about addressing these problems?

I am not prepared to wipe the OS and start from scratch:

1) I've heard horror stories about bad reinstalls and could stand to lose apps and / or data.

2) This computer is an important research tool that I am using to conduct research overseas. Downtime or longtime loss of use is not an option, as I am trying to actively entering data on a regular basis into Office and other programs.

Help please, this becoming a real nuisance.


:huh: :thumbsup:

BC AdBot (Login to Remove)



#2 garmanma


    Computer Masochist

  • Staff Emeritus
  • 27,809 posts
  • Location:Cleveland, Ohio
  • Local time:11:23 PM

Posted 03 November 2008 - 05:37 PM

I wonder if you can somehow use "Take ownership of a file or folder" in this situation:
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users