Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


file or directory is corrupt and unreadable

  • Please log in to reply
3 replies to this topic

#1 Frank Taplin

Frank Taplin

  • Members
  • 1 posts
  • Local time:04:42 PM

Posted 24 October 2008 - 09:35 AM

I have a customers computer that is running Vista home premium sp1. The programs that are already installed on it run fine. When you try to install a new program it gives an error that says "ShellExecuteEx failed; code 1392. the file or directory is corrupted and unreadable." or just "the file or directory is corrupted and unreadable." You can download program files just fine but when you try to run them you get the error. The same occurs when you try to run things from a flash drive or CD. The files on the flash drive or CD are good because you can run them on another computer just fine.
The computer has Windows Defender and Ad Aware 2008 on it and I ran those to check for malware but they don't detect anything. I also tried running Trendmicro and Bitdefender online scans but got the same errors on those. Panda ActiveScan ran and didn't detect anything.
The computer has AVG 8.0 on it and doesn't detect any virus or spyware at all.
I've tried running the registry editor on Ccleaner but it doesn't find any errors.
I've tried running chkdsk several times but it doesn't detect any problems. I've also tried to do the repair computer option from the advanced startup menu but nothing changes.
I've tried to boot into Safe Mode but I still get the same results.
I've tried searching technet and other forums but with no luck.
Any ideas?

BC AdBot (Login to Remove)


#2 DJBPace07


  • BC Advisor
  • 4,869 posts
  • Gender:Male
  • Local time:05:42 PM

Posted 25 October 2008 - 01:45 AM

Since you're able to use TechNet, I assume you are experienced. There could be a problem with how Windows is using the ShellExecuteEx command if you are able to access the files on another PC. Have you tried doing a system restore to when your PC worked normally? There is little information on the 1392 error code.



#3 usasma


    Still visually handicapped (avatar is memory developed by my Dad

  • BSOD Kernel Dump Expert
  • 25,091 posts
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:05:42 PM

Posted 25 October 2008 - 05:48 AM

Try SFC.EXE /SCANNOW to see if it's one of the protected files.
As an outside shot, try a diagnostic on the hard drive to see if it's failing.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#4 KTFire


  • Members
  • 5 posts
  • Gender:Female
  • Location:Florida
  • Local time:05:42 PM

Posted 27 October 2008 - 12:43 PM

Just out of curiousity, try right clicking on one of the files you downloaded and go to properties.
At the bottom of the properties window look for a new section labeled Security just below the Attributes section. You should see an Unblock button if it's there.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users