Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Multiple problems with WD Passport


  • Please log in to reply
1 reply to this topic

#1 kpw001

kpw001

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:52 AM

Posted 22 October 2008 - 08:51 PM

About a few months ago, I bought the WD Passport Essentials 250GB external drive. The first thing I did was format it, I didn't need any of the software, I bought it because it was a decent price and such. At first there were no problems, then in the last few weeks it has all gone down hill...

1) when copying files over, it hangs and then locks up my entire system. No response to keyboard or mouse, I have to pull the plug on the drive before my system frees up again.

2) I tried a number of different USB cables, again the same problems. It works fine for a while, then locks up again later on.

3) after doing a google search, I find that WD has issues with power consumption and their USB to SATA connection used on the Passport drives so I decided to pull the drive out and replaced the enclosure with a Vantec NexStar CX case. This worked for a week or so.

4) the same problem comes up again, so i try the y-cable that came with the Vantec case. It has two USB connections to draw power from a second USB port. No luck either.

5) lastly, i disabled the Reduced Power Spinup jumper (this is the factory setting) and it worked for a while until just now when mid-transfer the drive just powers off.

I use this drive on a Dell Dimension 2400 running Windows XP Pro. The drive it self is a WD Scorpio Blue 1.5Gb/s. I have run Check Disk as well as deleting the partition, nothing seems to be a fix to this. There were no errors on the disk. I've also connected it using every USB port on my computer. Is this an issue with Passport drives or just my bad luck of getting a bad drive? Any one else have problems like this before?

Edited by kpw001, 22 October 2008 - 08:55 PM.


BC AdBot (Login to Remove)

 


m

#2 hamluis

hamluis

    Moderator


  • Moderator
  • 54,865 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:52 AM

Posted 23 October 2008 - 11:55 AM

Hi :thumbsup:.

First...if you think it's a WD Passport problem...why not RMA the thing?

I'm sure the warranty period hasn't expired in a few months.

Second...the weak link in any external drive is the enclosure, not the drive itself (IMO). This can normally be verified by taking the drive from the enclosure and connecting it (properly) directly to the motherboard.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users