Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No audio device detected, no sound?


  • Please log in to reply
1 reply to this topic

#1 Nightspear

Nightspear

  • Members
  • 364 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:46 PM

Posted 18 October 2008 - 11:34 PM

I see that there are a lot of people here that are having the same problem. This is what I found that restored my sound

Problem
- Under 'Sound and Audio Devices' on the Control Panel: 'No Audio Device' under the 'Volume' tab
- Device installed properly in Device Manager
- Some audio in some programs (I was able to get it to work properly in Windows Media Player before a complete fix by going to Tools -> Options -> Devices -> Speakers -> Properties -> Select your sound card)
- Various driver solutions (new, old, from manufacturer, install CD, etc.) don't work

Other symptoms I experienced which other seekers might find useful

- Using run -> dxdiag: go to the 'Sound' tab and 'Test DirectSound' My results were 'DirectSound test results: Failure at Step3 (DirectSoundCreate): HRESULT = 0x8878000a'
- It didn't matter what sound card I used, onboard or an add-in PCI card
- The BIOS settings for the onboard sound were correct and disabled when using the add-in PCI card
- WMP would return an error (before I used the above fix) of C00D11BA

The solution that fixed it for me:
1 - run -> services.msc
2 - Find the 'Windows Audio' service
3 - If it's set to 'Manual' or 'Disabled', there's your problem. Right-click on it to pull up the properties and set it to 'Automatic'
(If the service was set to 'Manual', it's an on-demand setting which might explain why some users were able to use sound after a driver install [flicks service 'on'] but not after a reboot [no installation program to flick the switch] It would explain Creative diagnostics getting sound too)
4 - Start the service and hopefully you'll get sound

BC AdBot (Login to Remove)

 


#2 allofmeisu

allofmeisu

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:46 PM

Posted 30 January 2011 - 12:26 AM

Thank you very much for this info. I've been trying to fix this problem for a month now and I've searched for possible solutions that never worked for me, and finally today, I stumbled on this and solved my problem. Thanks alot, nightspear :thumbsup2:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users