Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Printer Wont Work Through Usb Hub


  • Please log in to reply
5 replies to this topic

#1 spunks3

spunks3

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:01:11 AM

Posted 29 September 2008 - 01:47 AM

Im running on Vista.

I purchased a usb hub that ads four more ports to my laptop. I can use it fine with my mous and also my external hard drive. but when i plug my printer into it and try to print a document from MS Word, it wont find the printer. In the lower right corner it will say that an unknown device is connected... if i plug the printer into a USB port directly on the PC it will work, but that kind of defeated the entire purpose of having the HUB, i dont want to have to keep un-plugging and re-plugging things in.

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:02:11 AM

Posted 29 September 2008 - 10:58 AM

Does the hub get its power from the laptop or it's own separate power supply?
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 spunks3

spunks3
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:01:11 AM

Posted 29 September 2008 - 10:34 PM

from the PC itself

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,416 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:11 AM

Posted 30 September 2008 - 10:27 AM

Have you tested all the ports on the hub...with other USB devices?

Louis

#5 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:02:11 AM

Posted 30 September 2008 - 10:36 AM

In the lower right corner it will say that an unknown device is connected..


Did you install the software before attaching the printer?
You can try going to Device Manager and delete the USB root hub controllers and reboot the computer and reload them and see what happens. Personally, I'd go with one that has its own power supply
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#6 spunks3

spunks3
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:01:11 AM

Posted 30 September 2008 - 03:51 PM

hmmm... idk if this had anything to do with it, but i uninstalled the IE 8 beta 2, and reset, then reinstalled it, reset and now my printer seems to be working through the HUB... thanks for the help!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users