Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Play All Option In Windows Explorer


  • Please log in to reply
12 replies to this topic

#1 dc2000

dc2000

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:12:39 PM

Posted 15 September 2008 - 11:35 PM

Hi everyone:


I had a recent infection on my PC and had to reinstall Windows Media Player after I reverted back to XP SP1 (from SP2) and then to SP3. Now I installed WMP 11 and it works fine except one thing. There is this Play All link in Windows Explorer that was very useful for me before to play all the clips in a folder, which somehow doesn't work anymore. If I click it, nothing happens.

To explain what I mean, I'm attaching a screen shot.

Can someone suggest how to make this feature work again?

Attached Files



BC AdBot (Login to Remove)

 


#2 E-Mu

E-Mu

    Bleepin' Psychopomp


  • Members
  • 1,386 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 16 September 2008 - 04:04 AM

Normally Caused by:

1 - Incorrect file association settings
2 - A third-party shell is extension blocking the Play all feature

We'll start with the easiest,

Go to, Start, then Run and type: regsvr32 wmpshell.dll

And then run this command: %Systemroot%\INF\unregmp2.exe /SetWMPAsDefault

Reboot and then try again. Post back with results.

E-Mu

(Edit: rearranged post)

Edited by Emu1616, 16 September 2008 - 04:05 AM.

~ E-Mu ~

"Emu, You Moo, We All Moo for Emu!" <-- Thanks to Animal

"If at first you don't succeed; call it version 1.0"


#3 dc2000

dc2000
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:12:39 PM

Posted 16 September 2008 - 12:57 PM

Sorry, man, it didn't help. What happens is that I can see that Explorer is doing something (the mouse turns into an hour glass for a second or so) but then it returns back into the pointer and nothing happens.

#4 E-Mu

E-Mu

    Bleepin' Psychopomp


  • Members
  • 1,386 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 16 September 2008 - 01:31 PM

Ok,

Make sure Windows Media Player is set as the default media player for supported file types. Start Windows Media Player. In Windows Media Player, click on tools and click on options. Navigate to the File types tab and click on select all. Click on OK and exit Windows Media Player.

Next would be to disable third-party shell extensions that could be blocking the command.

Alt:- Go tot he folder which holds the music files, press ctrl + A to select all files, then right click and go to Queue-It-Up, this will add all the files to WMP and start playing.

E-Mu
~ E-Mu ~

"Emu, You Moo, We All Moo for Emu!" <-- Thanks to Animal

"If at first you don't succeed; call it version 1.0"


#5 dc2000

dc2000
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:12:39 PM

Posted 16 September 2008 - 01:59 PM

I just checked the file associations in WMP (Tools -> Options -> File Types) and did Select All -> OK. But still nothing happens. (As for Ctrl+A, right-click and then "Queue-It-Up", then I don't have that option in the context menu.) If I click Play instead, all those tracks start playing in WMP, and of cource I can use it, but it's inconvenient. That Play All option was very nifty.

I also checked Windows Explorer -> Tools -> Folder Options -> File Types and MP3 file type is associated with WMP only. I checked all the tracks in the folder I want to play, and they all are of MP3 type.

Thank you for trying to help!

#6 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:07:39 PM

Posted 16 September 2008 - 02:31 PM

Have a read here:Play All Option Missing

Also here:Play All Option Missing

Edited by cryptodan, 16 September 2008 - 02:33 PM.


#7 E-Mu

E-Mu

    Bleepin' Psychopomp


  • Members
  • 1,386 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 16 September 2008 - 04:34 PM

Have a read here:Play All Option Missing

Also here:Play All Option Missing


2nd link here is in relation to mobile phones.


Editing your registry is very dangerous unless you know what you are doing, one wrong move and you could rendor your PC useless (and a expensive paper weight), not something i would feel comfortable talking you through im afraid.

However i would check out this link as a last attempt from me.

Scroll down to where it starts Method 2, and read from ther.

E-Mu
~ E-Mu ~

"Emu, You Moo, We All Moo for Emu!" <-- Thanks to Animal

"If at first you don't succeed; call it version 1.0"


#8 dc2000

dc2000
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:12:39 PM

Posted 17 September 2008 - 03:11 AM

Sorry, guys still no luck :thumbsup:

The registry fix above did nothing except erasing all of my folder settings (icon views, etc), so now they all look like if I just installed Windows. (That will require some additional work for me to rearrange them back, but that's OK.)

As for ShellExView, then it reports .mp3 and .wma extensions to be handled by:
Audio Media Properties Handler
C:\WINDOWS\System32\shmedia.dll
{875CB1A1-0F29-45de-A1AE-CFB4950D0B78}

You see, unlike those posts you pointed me to above, the Play All link in my case is visible and pretty much clickable. It just doesn't do anything.

I had no idea this will be so hard to fix...

#9 E-Mu

E-Mu

    Bleepin' Psychopomp


  • Members
  • 1,386 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 17 September 2008 - 03:21 AM

To be honest mate i honestly don't know now, i've not got anything else you could try.

The only thing i could suggest is email MS, or search every corner of google to try and find the solution.


Sorry bud!

E-Mu
~ E-Mu ~

"Emu, You Moo, We All Moo for Emu!" <-- Thanks to Animal

"If at first you don't succeed; call it version 1.0"


#10 dc2000

dc2000
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:12:39 PM

Posted 17 September 2008 - 02:20 PM

Hey, thanks anyway. You said to email Microsoft, I didn't know it was actually possible. How'd you do that? I also thought that they stopped support for XP already.

#11 E-Mu

E-Mu

    Bleepin' Psychopomp


  • Members
  • 1,386 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 17 September 2008 - 02:55 PM

Have a look here for contacting Microsoft.

They extended the free support for XP until April 2009, then after April 2009 there's 5years support left but anything asides security updates will be charged for.
Something to do with Microsoft's policy of curtailing its support for an edition of Windows two years after a new version hits the market. (according to sources at msnbc)

E-Mu
~ E-Mu ~

"Emu, You Moo, We All Moo for Emu!" <-- Thanks to Animal

"If at first you don't succeed; call it version 1.0"


#12 dc2000

dc2000
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:12:39 PM

Posted 20 September 2008 - 11:37 AM

Thanks, man. Sorry, for delayed response. Somehow I didn't get an email when you posted your comment.

I'll submit this same question to the MS and if they give me an answer I'll post it here.

#13 E-Mu

E-Mu

    Bleepin' Psychopomp


  • Members
  • 1,386 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:07:39 PM

Posted 20 September 2008 - 12:55 PM

No problem,

Be intrested to hear if they have a fix
~ E-Mu ~

"Emu, You Moo, We All Moo for Emu!" <-- Thanks to Animal

"If at first you don't succeed; call it version 1.0"





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users