Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Automatic Disk Defrag Problem


  • Please log in to reply
12 replies to this topic

#1 j0nath4n

j0nath4n

  • Members
  • 81 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Someplace where it rains.
  • Local time:03:05 PM

Posted 14 September 2008 - 02:51 AM

Recently,whenever I try to open C Drive or any other drive,it comes up with this message:

Posted Image
The only way to open the files is to right click the drive and click Open.

Edited by j0nath4n, 14 September 2008 - 02:53 AM.


BC AdBot (Login to Remove)

 


#2 rowal5555

rowal5555

    Just enough info to be armed & dangerous...


  • Members
  • 2,644 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St Kilda, Dunedin. South Island. NZ
  • Local time:08:05 PM

Posted 14 September 2008 - 03:55 AM

Hi jOnath4n

As it says, your C: drive is overcrowded and is choking itself. For a start, I would run DISK Cleanup at Start/All Programs/System Tools. Then go to Control Panel/Add-Remove and get rid of all unnecessary programs. For a 145GB drive, you will need at least 22 GB free, but this is the absolute minimum so go for your life and have a good dungout.

Another way would be to install a second drive, either internally or via USB, and transfer a lot of your data onto that. Drives are very cheap these days - just make sure you get the same type.

Let us know how you go. Good luck.

rowal5555 (Rob )                                                             

Avid supporter of Bleeping Computer's
Team 38444

You can help find a cure


 


#3 j0nath4n

j0nath4n
  • Topic Starter

  • Members
  • 81 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Someplace where it rains.
  • Local time:03:05 PM

Posted 15 September 2008 - 01:34 AM

No luck.I uninstalled as many programs as possible,now I'm left with more than 22 GB,but the message still comes out.Could it be something I did?I remembered messing around with the Folder Options stuff recently.

#4 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:05 PM

Posted 15 September 2008 - 01:42 AM

Go back into Folder Options and click the Restore Defaults button.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#5 rowal5555

rowal5555

    Just enough info to be armed & dangerous...


  • Members
  • 2,644 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St Kilda, Dunedin. South Island. NZ
  • Local time:08:05 PM

Posted 15 September 2008 - 02:03 AM

I  can't think of anything particularly in Folder Options that would affect things. Make sure that the "Hide protected System Files" is checked, as you can hose your system very easily if these are out in the open.

I don't know if this will help but it won't do any harm. Start/Run and type in cmd and press OK. In the box that comes up, type exactly, chkdsk(space)/r  Don't type space of course.

You will be told that a checkdisk will be scheduled for the next reboot. Agree to everything and reboot. Chkdsk will take quite a while so go and do something else for a while and see what happens.

rowal5555 (Rob )                                                             

Avid supporter of Bleeping Computer's
Team 38444

You can help find a cure


 


#6 j0nath4n

j0nath4n
  • Topic Starter

  • Members
  • 81 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Someplace where it rains.
  • Local time:03:05 PM

Posted 15 September 2008 - 02:34 AM

Ok.Scheduled for the next reboot.I have a question:I tried creating a new DeviceStoragePolicies folder in my registry due to my mem card stating that it is write protected when it was fine the day before.I changed the DWORD to 0.But it is still giving the same message.My card has no lock switch.It's just a card.

#7 rowal5555

rowal5555

    Just enough info to be armed & dangerous...


  • Members
  • 2,644 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St Kilda, Dunedin. South Island. NZ
  • Local time:08:05 PM

Posted 15 September 2008 - 04:21 AM

Don't know about that one.

rowal5555 (Rob )                                                             

Avid supporter of Bleeping Computer's
Team 38444

You can help find a cure


 


#8 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:07:05 AM

Posted 15 September 2008 - 04:24 AM

Does it have a software lock on the card?

#9 j0nath4n

j0nath4n
  • Topic Starter

  • Members
  • 81 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Someplace where it rains.
  • Local time:03:05 PM

Posted 19 September 2008 - 03:06 AM

Does it have a software lock on the card?

Nope.Just as it is.I can't even rename the files on my MMC.

Back to original question:
Ok,I must strangle myself for this.I did the chkdsk halfway through,I got really bored and just switched it off and restarted the PC.Now whenever I access some files,a pop-up shows that C:\$Secure is corrupted and unreadable.But so far the PC works like normal except a few files.What do I do next?

Edited by j0nath4n, 19 September 2008 - 03:09 AM.


#10 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:05 PM

Posted 19 September 2008 - 04:48 PM

Run chkdsk again but this time let it finish.
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw

#11 j0nath4n

j0nath4n
  • Topic Starter

  • Members
  • 81 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Someplace where it rains.
  • Local time:03:05 PM

Posted 19 September 2008 - 11:06 PM

Finished,no more pop-ups but the original problem persists.

#12 j0nath4n

j0nath4n
  • Topic Starter

  • Members
  • 81 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Someplace where it rains.
  • Local time:03:05 PM

Posted 22 September 2008 - 03:46 AM

Bumped.

#13 Budapest

Budapest

    Bleepin' Cynic


  • Moderator
  • 23,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:05 PM

Posted 22 September 2008 - 04:27 PM

Try defragging the C: drive in Safe Mode.

How to start Windows in Safe Mode
The power of accurate observation is commonly called cynicism by those who haven't got it.

—George Bernard Shaw




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users