Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Broken Print Spool Service


  • Please log in to reply
3 replies to this topic

#1 fluxx23

fluxx23

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ann Arbor, MI
  • Local time:10:04 AM

Posted 01 September 2008 - 03:41 PM

I'm working on restoring a printer after a virus removal. The virus seems to have been completely removed via McAfee agent connecting VNC to this computer and removing it. Well since then the printer is not working.

I can not simply add a printer due to this error:

"Operation could not be completed. The print spooler is not running."

So I tried to start the service but then I get this:

"Error 2: Could not find the file specified."

From here I checked the %systemroot%\system32 and could not find the spoolsv.exe file. RPC service is running but when I try to run a:

expand -r h:\i386\spoolsv.ex_ c:\windows\system32\spoolsv.exe

It tells me that it can not find the input file or the output file. I've tried booting into safe mode, I've tried loading an UBCD4Win and I get smiliar errors each time. Are there any other work arounds for this?

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:10:04 AM

Posted 01 September 2008 - 05:37 PM

Do you have an H: drive and does it have an i386 sub-directory on it? Have you checked inside there to see if the spoolsv.ex_ file exists. It may be in another subdirectory - or it may be in one of the .cab files. Locating it will be the key to expanding it.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 fluxx23

fluxx23
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ann Arbor, MI
  • Local time:10:04 AM

Posted 01 September 2008 - 06:09 PM

I feel like an idiot. Well, I found in the i386\System32 directory a expanded version of spoolsv.exe, so I copied that and it worked...almost.

Now when I go to add the printer, it simply says "Operation could not be completed."

Then, as I just noticed, it seems as soon as I shut the services/printer window down, the service shuts off.

The service is set to automatic. Run as local system account, and on first or second failure, restart itself.

My guess is something doesn't want this service to run and is shutting it down. But how could I know?

#4 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:10:04 AM

Posted 02 September 2008 - 06:42 AM

What errors are shown (when this happens) in Event Viewer?
Go to Start...Run...and type in "eventvwr.msc" (without the quotes) and press Enter.
Most likely the errors will be in the System logfile, but I'd check the Application logfile just to be sure.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users