Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Lm-sensors & Ubuntu 8.04


  • Please log in to reply
18 replies to this topic

#1 Jim P

Jim P

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 30 August 2008 - 06:18 PM

My first problem with Ubuntu 8.04. So far everything I've thrown at Ubuntu has worked flawlessly. I installed the LM-Sensor package and nothing. Did I miss something??? :thumbsup:

Regards

Jim

BC AdBot (Login to Remove)

 


#2 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:49 PM

Posted 02 September 2008 - 07:10 PM

After install did you run - "sensors-detect" as root. (or sudo sensors-detect)?

rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#3 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 02 September 2008 - 07:20 PM

After install did you run - "sensors-detect" as root. (or sudo sensors-detect)?


Don't think so. How do you do that?

Jim

#4 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:49 PM

Posted 02 September 2008 - 08:15 PM

Applications - Accessories - Terminal
In the terminal type: sudo sensors-detect
Follow the prompts.

rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#5 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 02 September 2008 - 08:33 PM

Applications - Accessories - Terminal
In the terminal type: sudo sensors-detect
Follow the prompts.



I did that, still not working.

The last ? asks if you want to automatically do something (can't recall the exact terminology) the default answer is no. I hit enter and it goes back to the beginning. All the other default answers are yes the last one is no. Tried to figure out how to change it to yes, but haven't quite gotten there.

I hate the terminal :thumbsup:

Jim

#6 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:49 PM

Posted 02 September 2008 - 10:53 PM

Do you want to generate /etc/sysconfig/lm_sensors? (YES/no):

That is my last line. To change the default simply type: yes
then press enter. You can load the modules by hand or a reboot
should start lm_sensors and load the correct modules.

rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#7 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 03 September 2008 - 06:29 AM

Do you want to generate /etc/sysconfig/lm_sensors? (YES/no):

That is my last line. To change the default simply type: yes
then press enter. You can load the modules by hand or a reboot
should start lm_sensors and load the correct modules.


That's not my last line.

When I enter yes or no it goes back to the beginning.

It also says something about chip drivers it87 and coretemp are needed. I'm really lost now.

Jim

Edited by Jim P, 03 September 2008 - 07:08 AM.


#8 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:49 PM

Posted 03 September 2008 - 06:01 PM

Highlite the output with your mouse and hit "CTRL - C" to copy the
text and post here so I can see what you see.

rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#9 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 07 September 2008 - 06:05 PM

Highlite the output with your mouse and hit "CTRL - C" to copy the
text and post here so I can see what you see.



I guess I don't know what you're telling me to do. Highlight the output???

Thanks for all the help.

Jim

#10 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:49 PM

Posted 07 September 2008 - 06:31 PM

Sorry...just copy the text from the terminal like you
copy any text.

rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#11 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 07 September 2008 - 07:37 PM

Sorry...just copy the text from the terminal like you
copy any text.



I tried that.

When I right click the mouse and hit copy it doesn't do anything. Copy and Paste aren't highlighted.

Jim

#12 smurfgod

smurfgod

  • Members
  • 446 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Illinois
  • Local time:03:49 PM

Posted 08 September 2008 - 04:57 AM

thats why he gave you the keyboard shortcuts. Highlight the line and hit Control+C at the same time

#13 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 08 September 2008 - 05:43 AM

This is what I came up with, maybe it will help.

Jim


Driver `it87' (should be inserted):
Detects correctly:
* ISA bus, address 0x290
Chip `ITE IT8718F Super IO Sensors' (confidence: 9)
Driver `coretemp' (should be inserted):
Detects correctly:
* Chip `Intel Core family thermal sensor' (confidence: 9)
I will now generate the commands needed to load the required modules.
Just press ENTER to continue:
To load everything that is needed, add this to /etc/modules:
#----cut here----
# Chip drivers
it87
#----cut here----
Do you want to add these lines automatically? (yes/NO)

Edited by Jim P, 08 September 2008 - 05:46 AM.


#14 raw

raw

    Bleeping Hacker


  • Members
  • 2,577 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:49 PM

Posted 09 September 2008 - 09:16 PM

Looks like it might be a kernel bug for Intel CPU.
I want you to try loading the modules by hand.
Open your terminal and type:
sudo modprobe coretemp
sudo modprobe it87
If both modules load with no errors type:
sensors
And see if you get any readings.

rawsig.png

 rawcreations.net          @raw_creations


Current systems: WHAT OS, BackTrack-raw, PCLinuxOS, Peppermint OS 6, Kali Linux

and a custom Linux From Scratch server hosting a bunch of top secret stuff.


#15 Jim P

Jim P
  • Topic Starter

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Local time:03:49 PM

Posted 09 September 2008 - 09:38 PM

Like these :thumbsup:


coretemp-isa-0000
Core 0:
Adapter: ISA adapter
Core 0: +38.0C (crit = +100.0C)

it8718-isa-0a10
Adapter: ISA adapter
in0: +1.06 V (min = +0.00 V, max = +4.08 V)
in1: +1.82 V (min = +0.00 V, max = +4.08 V)
in2: +2.03 V (min = +0.00 V, max = +4.08 V)
in3: +2.85 V (min = +0.00 V, max = +4.08 V)
in4: +2.03 V (min = +0.00 V, max = +4.08 V)
in5: +0.06 V (min = +0.00 V, max = +4.08 V)
in6: +1.42 V (min = +0.00 V, max = +4.08 V)
in7: +2.93 V (min = +0.00 V, max = +4.08 V)
in8: +3.18 V
fan1: 0 RPM (min = 0 RPM)
fan2: 1991 RPM (min = 0 RPM)
fan3: 0 RPM (min = 0 RPM)
temp1: +25.0C (low = -1.0C, high = +127.0C) sensor = transistor
temp2: +128.0C (low = -1.0C, high = +127.0C) sensor = disabled
temp3: +23.0C (low = -1.0C, high = +127.0C) sensor = thermal diode
cpu0_vid: +1.700 V




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users