Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internet Disconnect


  • Please log in to reply
6 replies to this topic

#1 sam-my

sam-my

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:06:23 PM

Posted 18 August 2008 - 04:16 PM

I have a desk PC connected to a router and two laptops connected (wireless) to this PC. One Laptop is running Windows XP pro
and the second one Vista Home Premium.
We have no problem surfing the net with both laptops.
The issue is when the laptop using the Vista is at rest for approximately 15 minutes, the internet is disconnected (a red 'X' appears on the
internet connection icon on the system tray) and all the attempts to reconnect the internet fail (right clicking on the icon on the system tray, or through the Control Panel" "network and Internet" icon). The lonely solution is to restart the laptop.
I have not this issue with the laptop running XP pro

Asking for assistance. Thanks

BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:07:23 PM

Posted 18 August 2008 - 04:35 PM

I would suggest disabling the DHCP Broadcast Flag on the Vista computer. Here's an article with instructions: http://support.microsoft.com/default.aspx/kb/928233

If that doesn't fix it, post back and we'll move this over to the Networking forum.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 sam-my

sam-my
  • Topic Starter

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:06:23 PM

Posted 20 August 2008 - 01:54 PM

Thanks Usasma for your prompt answer.
I modified the registry as per the attached instructions. That solved the problem "partially".
i.e. now the internet is re-connecting without the need to restart the computer, but I remarked,
that when the computer is at rest it went "dormant" after 10 minutes: the monitor went black (off) and most of the lights on the laptop
board went off also (except the light on the switch ON/OFF) - it seems IMHO that this is for saving energy .
To re-activate the computer I touch the board pad/mouse and then all the lights ( and the monitor) come to "life".
When that happens, I can see the red "X" on the internet connection icon located on the System tray, which disappeared immediately,
allowing the PC to connect to the internet with no need of restart (as before the registry modification).

The problem is, when the PC is "dormant" (i don't know how to call to this state), the internet is disconnected, and then programs like Messenger or Skype are disconnected also.
How to prevent that?

Thanks

#4 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,090 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:07:23 PM

Posted 20 August 2008 - 02:57 PM

I believe that what you're referring to is the Sleep, Hybrid Sleep, or Hiberantion mode offered on today's systems.

First, what the DHCP Broadcast Flag thing does is it turns of the DHCP Broadcast Flag. This works because some hardware between you and the internet isn't Vista compatible. Most likely this is your router - and a firmware update may be in order there. That will simplify some of your issues.

As for the Messenger or Skype programs being able to connect in this state - it can't happen easily. The Sleep/Hybrid Sleep/Hibernation feature is a power saving feature that turns off the computer and saves your work so it can be easily restored later on.

I don't know of any reliable, secure way to do this (although I suspect that there are solutions available on the web) - so I'd have to suggest leaving the system on to receive calls. You can adjust the power settings by going to Start...Control Panel...System and Maintenance...Power Options.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#5 Jacee

Jacee

    Bleeping around


  • Malware Response Team
  • 3,716 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:04:23 PM

Posted 20 August 2008 - 02:59 PM

Go to your Control Panel, click on "Power Options". Click on "Change when the Computer Sleeps" (left column) ... then click on 'change Advanced power settings'. I have mine set to never put the computer to sleep or turn off the display. I use a screen saver. If I'm going to be away from the computer for a few hours, I shut it down.

MS_MVP.gif
MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop


#6 sam-my

sam-my
  • Topic Starter

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:06:23 PM

Posted 20 August 2008 - 05:13 PM

Jacee

Please I would like to ask for clarification:
1. After clicking on "Change when the Computer Sleeps" I've got the "Change Settings for the plan: HP recommended" with the following times:
"Turn off the display":
'On Battery': 5 minutes
' Plugged in': 15 minutes

" Put the computer to sleep":
'On Battery': 10 minutes
' Plugged in': 25 minutes

Which time settings do I have to change to "Never"

2. When I clicked 'Change Advanced power settings' I've got, the in the main button, "HP recommended (active)" with additional options..
Which settings do I have to change in the main column with the cursor, in order to cancel the 'sleep' feature:
'Wireless Adapter Settings' or
'Sleep' or
'Display' ....etc...

Thanks for your kind assistance

#7 Jacee

Jacee

    Bleeping around


  • Malware Response Team
  • 3,716 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:04:23 PM

Posted 20 August 2008 - 08:25 PM

I don't have an OEM computer, so my settings aren't recommended by a manufacturer

This is what I can show you:
First, click on 'create a power plan' Posted Image

Next, look for your options in the dropdown box and check 'never' Posted Image

Edit... I have my laptop power supply plugged in. I don't run it on battery.

Edited by Jacee, 20 August 2008 - 08:27 PM.

MS_MVP.gif
MS MVP Windows-Security 2006-2016
Member of UNITE, the Unified Network of Instructors and Trusted Eliminators

Admin PC Pitstop





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users