Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Esata Drive Not Reading


  • Please log in to reply
15 replies to this topic

#1 dthomasss

dthomasss

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 16 August 2008 - 07:19 AM

I bought an external Seagate 750 GB Free Agent drive. It works fine in USB mode, but my computer does not see it when I try to connect with the Esata cable. I have an Asus P5K MB and running XP. Any suggestions?

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,272 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:04:48 AM

Posted 16 August 2008 - 01:22 PM

Well...does an eSATA connection call for a driver?

If so, was said driver installed?

Check Device Manager for clues?

You mean that this drive appears properly in My Computer/Explorer when connected by USB?

Is the drive formatted?

Louis

Edited by hamluis, 16 August 2008 - 07:28 PM.


#3 Platypus

Platypus

  • Global Moderator
  • 15,173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:08:48 PM

Posted 16 August 2008 - 06:01 PM

Ensure the eSATA port is enabled in the BIOS setup. If XP doesn't have SATA drivers installed (ie the system's internal HDD and optical drive are IDE), the motherboard SATA drivers will need to be installed, or the port will have to be set to emulate IDE if such an option is available in the BIOS. It may not be, as IDE has no hotswap capability, which rather defeats the purpose of eSATA.

There's also a slight possibility that the eSATA connection on the enclosure simply doesn't work.
Top 5 things that never get done:

1.

#4 dthomasss

dthomasss
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 16 August 2008 - 08:20 PM

My internal hard drives are both SATA. The drive is formatted and reads fine in USB. But I just discovered it will read it if I plug it in at bootup. I guess it is not a hot-swappable :thumbsup:

Edited by dthomasss, 17 August 2008 - 12:19 AM.


#5 Platypus

Platypus

  • Global Moderator
  • 15,173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:08:48 PM

Posted 17 August 2008 - 06:00 AM

My internal hard drives are both SATA. The drive is formatted and reads fine in USB. But I just discovered it will read it if I plug it in at bootup. I guess it is not a hot-swappable :thumbsup:

eSATA should be hot-swappable.

If you haven't already, double check that the SATA drives aren't being operated in IDE emulation mode. XP could still have been installed without SATA drivers by this means.

Or even if the internal drives are being operated in AHCI mode and hence XP is using SATA drivers, if the eSATA channel has individual mode settings and is in IDE mode, Windows then uses its IDE drivers to access the eSATA drive. That will give the exact symptom you describe - if the drive is connected at boot-up, the IDE driver finds it, but IDE has no hot-swap capability, so cannot install a drive that is connected subsequent to boot time.

Edited by Platypus, 17 August 2008 - 06:01 AM.

Top 5 things that never get done:

1.

#6 dthomasss

dthomasss
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 17 August 2008 - 07:55 AM

Sorry.. can you repeat that in english lol

#7 Platypus

Platypus

  • Global Moderator
  • 15,173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:08:48 PM

Posted 18 August 2008 - 06:14 AM

I'll try, if you promise to read in English :thumbsup:

I scanned through the user manual for your board, and it's most likely that the eSATA port is just set to IDE mode.

The eSATA port is provided by the motherboard's second SATA controller, a J-Micron which has 3 selectable modes; RAID, IDE or AHCI (which means SATA). The manual says "The J-Micron controller item in the BIOS is set to [IDE] by default."

That means the eSATA port will make the eSATA drive appear to be an IDE drive, and Windows will use its own IDE driver for it, and not need a SATA driver. But it only works like an IDE drive, no hot-swap.

If you want to, you can download the manual and SATA driver from here:

http://support.asus.com/download/download....s&model=P5K

or the driver CD that came with the board or computer system would also have them on it.

The drivers for the J-Micron controller are in the section called RAID (because the controller can do RAID). If the XP driver was installed onto your computer, you could then go into the BIOS setup screen, and change the J-Micron controller mode to [AHCI] instead of [IDE].

Windows would then see the drive if it is plugged in after boot-up, and there would be a safe eject icon on the taskbar so the drive could be safely unplugged again without shutting the computer down.
Top 5 things that never get done:

1.

#8 dthomasss

dthomasss
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 18 August 2008 - 06:53 AM

I downloaded and installed the JMicron. I went into bios and the only option i saw under sata was IDE. Also when i open the Jmicron in windows.. it says J micron is not available in sata or ide but only in raid. Did i do something wrong?

#9 Platypus

Platypus

  • Global Moderator
  • 15,173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:08:48 PM

Posted 18 August 2008 - 08:40 AM

The J-Micron setting is not under the SATA section in the BIOS, that is for the internal SATA drives. The J-Micron has its own options in the Onboard Devices section of the Advanced menu. There's one option to Enable/Disable the J-Micron controller, the next option below that is Controller Mode [IDE, AHCI, RAID]. Select AHCI there.
Top 5 things that never get done:

1.

#10 dthomasss

dthomasss
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 19 August 2008 - 08:18 PM

I made the switch but it still doesn't read the drive in esata mode :thumbsup:

#11 Platypus

Platypus

  • Global Moderator
  • 15,173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:08:48 PM

Posted 20 August 2008 - 08:10 AM

Hmm, a Google search suggests you're not the only one with this sort of problem.

For example, it's long but this topic on the Seagate forums makes interesting reading:

http://forums.seagate.com/stx/board/messag...ding&page=1

Edited by Platypus, 20 August 2008 - 08:11 AM.

Top 5 things that never get done:

1.

#12 dthomasss

dthomasss
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 20 August 2008 - 07:14 PM

It looks my choices are to either use it at bootup, or else connect through USB. What a pain as I wanted faster write times. I use the drive to make a new weekly image file of my primary HD with Acronis True Image (the best disaster protection!) and also to store backups of movies, music etc.I should add that I did not buy the external drive. I purchased a Seagate Barracuda 750 GB internal SATA 300 and then bought an external Esata case for it.

Edited by dthomasss, 20 August 2008 - 07:34 PM.


#13 Platypus

Platypus

  • Global Moderator
  • 15,173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Australia
  • Local time:08:48 PM

Posted 21 August 2008 - 04:45 AM

If it's purely for backups and you're not really needing to move it around between systems, then not having the hotswap capability may not be much of a problem. Only my desktop system has eSATA, so I use my Vantec enclosure on USB with my laptops, & that works out OK.

Edited by Platypus, 21 August 2008 - 04:48 AM.

Top 5 things that never get done:

1.

#14 dthomasss

dthomasss
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Local time:04:48 PM

Posted 21 August 2008 - 05:27 AM

That's what I will do. It's just annoying to buy a product and not have it function properly...

#15 hamluis

hamluis

    Moderator


  • Moderator
  • 56,272 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:04:48 AM

Posted 21 August 2008 - 08:50 PM

Some of us...return things which we can prove are defective.

That's what warranties, RMAs, etc. are all about.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users