Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Questions Regarding Microsoft .net Framework


  • Please log in to reply
4 replies to this topic

#1 Tech8

Tech8

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:23 PM

Posted 12 August 2008 - 07:48 PM

Can anyone help me?

I have a computer running Windows XP Professional. I intend to install Microsoft .NET Framework, but am unsure which versions to install. I know some programs which require it will automatically install it, but was thinking of installing .NET Framework in advance.

I have a basic understanding of what it is -- a sort of programming environment for software developers, and needs to be installed in order to run programs developed using it.

I know there are currently five versions:

1.0 (I'm going to skip worrying about this one)
1.1 (Going to install this from Microsoft Update)
2.0
3.0
3.5

When I use Microsoft Update, the only versions which appear under Optional Software Updates is 1.1 and 2.0. Is there a reason 3.0 and 3.5 aren't listed? I can find them at the Microsoft Download Center. As far as I know, they can both be installed on XP.

http://www.microsoft.com/downloads/details...;displaylang=en
http://www.microsoft.com/downloads/details...;displaylang=en

More info I found:
http://en.wikipedia.org/wiki/.NET_Framework
http://askville.amazon.com/average-user-NE...questId=5096562

I'm trying to figure out if I should install 2.0, 3.0 and 3.5, or just 3.5?

From things I've read online, it definitely seems like 3.5 installs both 2.0 and 3.0, but I still feel uncertain. Is it the same 2.0 and 3.0 versions that will be needed for programs written specifically for 2.0 or 3.0? Or are they modified versions of 2.0 and 3.0 made to work for 3.5?

Should there be any problems installing 3.0 or 3.5 on XP, even though they don't appear on Microsoft Update for me?

Perhaps someone out there has more experience with .NET Framework and can tell me... I appreciate any assistance you can give.

BC AdBot (Login to Remove)

 


m

#2 hamluis

hamluis

    Moderator


  • Moderator
  • 54,818 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:23 PM

Posted 12 August 2008 - 08:41 PM

I installed 3.5 on this system.

3.5 includes updates to earlier versions, whether those versions are installed or not.

Any updates that you find at the WinUpdate site...are based on what is installed on your system. MS.NET itself is not a security update, but there are security updates which follow it...just as there are security updates for WMP and Internet Explorer.

If a program needs anything beyond 3.5, it will let you know.

The only reason I have it installed is because nLite asked for 2.0. I ignored that and 3.5 does the job.

You can install whatever...3.5 is probably the only version you need, if any. There are no compatibility problems with multiple versions on the same system.

Louis

#3 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:07:23 PM

Posted 13 August 2008 - 05:29 AM

I would install Microsoft.net Framework only if a program I was downloading required it. Otherwise it's not needed and doesn't actually do anything. I don't have it right now because I don't need it.

#4 Tech8

Tech8
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:23 PM

Posted 13 August 2008 - 05:04 PM

I intend to install the software which came with this Canon digital camera, and it says it requires .NET Framework 2.0. I was planning to install .NET in advance, because I know there will be other programs I'll want to run later which might need different versions of it. I'll just install 3.5 then, thanks for the advice, and all the help!

#5 hamluis

hamluis

    Moderator


  • Moderator
  • 54,818 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:23 PM

Posted 13 August 2008 - 07:19 PM

Easily done :thumbsup:.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users