Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Explorer.exe Improper Initiation Error 0xc0000022


  • Please log in to reply
11 replies to this topic

#1 snowman972

snowman972

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 07 August 2008 - 09:40 PM

When I log into my account on Windows XP, I get a error message saying "Explorer.EXE - The application failed to initiate properly" and all I see is my wallpaper. The computer stops responding. The error code is 0xc0000022. My brothers account works fine. He dosent get any errors. I think the problem might have been caused by a theme changing software. I have also scaned my computer with AVG. Nothing has changed. All accounts have administrative rights. Below is my HijackThis Log of my brothers account. Can I please get any help on this? This is very frustrating.

Edited by snowman972, 07 August 2008 - 09:45 PM.

Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,383 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:34 AM

Posted 08 August 2008 - 11:20 AM

Other instances of this error wound up doing repair installs.

I'd try running sfc /scannow first, with no great expectation that it will resolve the situation.

http://www.techsupportforum.com/microsoft-...0xc0000022.html

Louis

#3 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 08 August 2008 - 03:18 PM

Other instances of this error wound up doing repair installs.

I'd try running sfc /scannow first, with no great expectation that it will resolve the situation.

http://www.techsupportforum.com/microsoft-...0xc0000022.html

Louis


Thanks for your reply. I really appreciate it. I ran "sfc /scannow" command. Windows File Protection comes up and asks me for a Windows XP Pro. SP3 CD. I dont have one. Any help?
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,383 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:34 AM

Posted 08 August 2008 - 07:34 PM

What do you mean?

Do you have an XP install CD?

http://www.google.com/search?hl=en&q=slipstream+SP3

Louis

#5 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 08 August 2008 - 08:44 PM

No, I dont have a XP install disk. The system was already loaded with XP.
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

#6 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 15 August 2008 - 05:48 PM

Can anyone help me? I would really appreciate some help.
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

#7 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:34 AM

Posted 15 August 2008 - 07:17 PM

Please look at this post about using SFC.EXE ( http://www.bleepingcomputer.com/forums/t/43051/how-to-use-sfcexe-to-repair-system-files/ )

Look at the second post, and look for the text that starts with "To fix the problem when you only have a restore CD...." It's around the 3rd paragraph there.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#8 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 15 August 2008 - 08:50 PM

Please look at this post about using SFC.EXE ( http://www.bleepingcomputer.com/forums/t/43051/how-to-use-sfcexe-to-repair-system-files/ )

Look at the second post, and look for the text that starts with "To fix the problem when you only have a restore CD...." It's around the 3rd paragraph there.


Thank you for your reply. I am now follow the instructions for using SFC. But I have run into a problem. My System Restore does not work. I cant create a System Restore Point. I do not know why. I click on System Restore in system tools and System Restore does not come up. I do not know why this is. Other System Tools like System Information and Backup do not work either.
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

#9 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 15 August 2008 - 09:09 PM

Well, I went ahead and skipped creating the System Restore Point and followed the rest of the instructions. Nothing happened. SFC is still asking me for a CD and I didnt change the "sourcepath" Registry Key because it was already set to C:\.
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

#10 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 15 August 2008 - 09:14 PM

Well, I went ahead and skipped creating the System Restore Point and followed the rest of the instructions. Nothing happened. SFC is still asking me for a CD and I didnt change the "sourcepath" Registry Key because it was already set to C:\.
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)

#11 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:11:34 AM

Posted 16 August 2008 - 06:55 AM

I would suggest performing a couple of free online scans to see if anything has snuck by your AVG protection
(Be advised that some of these scanners will pickup things in "quarantine" from other anti-virus programs - so review the results carefully)

http://housecall.trendmicro.com
http://www.pandasecurity.com/homeusers/solutions/activescan/
http://www.kaspersky.com/virusscanner Scan Only - no removal
http://www.bitdefender.com/scan8/ie.html
http://support.f-secure.com/enu/home/ols.shtml
http://us.mcafee.com/root/mfs/default.asp
http://onlinescan.avast.com/
http://ca.com/us/securityadvisor/virusinfo/scan.aspx
http://www.eset.com/onlinescan/

<links compiled on 02/14/2008>

If there is an infection present, any further steps probably won't fix the issue - and will waste an awful lot of your time (and can cause the malware to become more difficult to remove). Once you're clean I'd suggest that the next step would be a repair install of Windows. Post back with the results of the scans and we'll move on from there.
My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#12 snowman972

snowman972
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Local time:09:34 AM

Posted 17 August 2008 - 10:11 PM

The problem has been fixed. This thread can be closed
Dell Dimension E310
2.80GHz Intel Pentium 4 w/ Hyper-Threading
2GB RAM
HIS Hightech 256MB ATI Radeon X1550 w/ Hyper-Memory (512MB)
70GB Hard Drive
DVD/CD-RW Drive (Bay 1)
DVD-RAM/DVD±RW/CD-RW Drive (Bay 2)
Microsoft Windows XP Media Center Edition 2002 (SP3)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users