Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External HDD not showing up


  • Please log in to reply
1 reply to this topic

#1 3mily

3mily

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:10 PM

Posted 03 August 2008 - 12:40 PM

Hope someone replies to this cuz I'm also trying to find answers for this problem!
Luckily it's my sister's external hardrive & not mine but she's not very teccy so I'm trying to find a fix for her!
She has a Maxtor desktop storage - unfortunately she was advised to transfer ALL her photo's onto it (shed loads of them!) Having kids, family holidays, pets & people that are no longer with us - the lot. Initially it worked fine, now she too has a power light on but the pc is not recognising it at all.

She took it to Curry's where they tried it on few pc's & found nothing. She rang pcworld up who said it's a minor problem easily fixed if taken to a decent repair place shouldn't cost anymore than 20.
She called the decent repair man who was shocked at their information & said it's far from minor & will probably require wrecking the box to get it open as it's sealed, then a circuit board will need replacing bla bla blaa etc - easily costing over 100!

She rang Maxtor all the way in the U.S & was talked (extensively!) through a few different procedures - still nothing.

I'm hoping someone on here has a clue on this cuz 10yrs worth of memories is a lot to lose to a little black box!

:thumbsup:

BC AdBot (Login to Remove)

 


#2 Dark-Myth

Dark-Myth

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:10 PM

Posted 05 August 2008 - 03:14 AM

If it's Maxtor, i've read a few solutions when searching for solutions to mine. Sadly, forgot the link.
But i suggest you try what I've done.

PS. list of things I've tried:
-Downloaded every Drive diagnostics software, and tried to see if they recognise it (http://www.tacktech.com/display.cfm?ttid=287#samsung)
-run --> cmd --> diskmgmt.msc (nothing there except C:\ and D:\(CD drive))
Got a pirate WinXP disk and see if my Drive shows up(i have proper WinXP by the way, OEM version, came iwht my DELL pc)
-Taken apart the enclosure, and reconnected, rescrewed the HDD to the board.
-tried unplugging and replugging it on 4 other PCs

Make sure you get the drivers for it, and try the HDD dianostic software, should be available from the manufacturer's website for free.
heres one of the solutions http://answers.yahoo.com/question/index;_y...25162415AAnjKL7
and some research that i've been doing for you, which i think has a similar problem to you
http://answers.yahoo.com/search/search_res...+not+showing+up

Hope this helps... :thumbsup:

lol i seem to replied to this topic on my topic lol




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users